Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163072 - freeradius is missing rlm_ldap.so
Summary: freeradius is missing rlm_ldap.so
Keywords:
Status: CLOSED DUPLICATE of bug 160877
Alias: None
Product: Fedora
Classification: Fedora
Component: freeradius
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-12 18:56 UTC by Florin Andrei
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-19 13:00:28 UTC


Attachments (Terms of Use)

Description Florin Andrei 2005-07-12 18:56:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The original FC4 freeradius has no rlm_ldap.so:

# rpm -ql freeradius | grep ldap
/etc/raddb/ldap.attrmap
/usr/share/doc/freeradius-1.0.2/rlm_ldap

However, after rebuilding the src.rpm on my FC4 system, the rebuild package has the LDAP module:

# rpm -qpl RPMS/i386/freeradius-1.0.2-2.i386.rpm | grep ldap
/etc/raddb/ldap.attrmap
/usr/lib/rlm_ldap-1.0.2.so
/usr/lib/rlm_ldap.so
/usr/share/doc/freeradius-1.0.2/rlm_ldap

What's funny is that BuildRequires specifies openldap-devel as a dependency, so it seems like there is an intention to provide LDAP auth. It's just the module that's missing from the package.

Version-Release number of selected component (if applicable):
freeradius-1.0.2-2

How reproducible:
Always

Steps to Reproduce:
1.see above
2.
3.
  

Actual Results:  see above

Expected Results:  Either the freeradius package should provide the LDAP module, or a freeradius-ldap package should be provided with FC4.

Additional info:

Comment 1 Thomas Woerner 2005-07-19 13:00:28 UTC

*** This bug has been marked as a duplicate of 160877 ***


Note You need to log in before you can comment on or make changes to this bug.