Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163062 - Default route not set for ath0 device after upgrade to Fedora Core 4
Summary: Default route not set for ath0 device after upgrade to Fedora Core 4
Keywords:
Status: CLOSED DUPLICATE of bug 149780
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-12 18:01 UTC by David Anderson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-19 10:31:14 UTC


Attachments (Terms of Use)

Description David Anderson 2005-07-12 18:01:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4) KHTML/3.4.1 (like Gecko)

Description of problem:
I have a Dell Inspiron laptop, with a Netgear wireless PCMCIA card, that has 
an Atheros chipset (Madwifi driver). 
 
Today I upgraded this machine from Fedora Core 2 to Fedora Core 4. 
 
Everything still works fine, networking-wise, except that when the ath0 
interface is brought up, the default route is not set: 
 
[root@shed network-scripts]# /sbin/route -n 
Kernel IP routing table 
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface 
[root@shed network-scripts]# /sbin/ifup ath0 
 
Determining IP information for ath0... done. 
[root@shed network-scripts]# /sbin/route -n 
Kernel IP routing table 
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface 
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 ath0 
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 ath0 
 
The ath0 device is configured for DHCP. Here is the DHCP lease: 
 
[root@shed network-scripts]# cat /var/lib/dhcp/dhclient-ath0.leases 
lease { 
  interface "ath0"; 
  fixed-address 192.168.1.3; 
  option subnet-mask 255.255.255.0; 
  option routers 192.168.1.1; 
  option dhcp-lease-time 259200; 
  option dhcp-message-type 5; 
  option domain-name-servers 192.168.1.1; 
  option dhcp-server-identifier 192.168.1.1; 
  renew 4 2005/7/14 02:04:09; 
  rebind 5 2005/7/15 08:58:08; 
  expire 5 2005/7/15 17:58:08; 
} 
 
Here is my ifcfg-ath0, (which as you can see has some settings left over from 
a static IP assignment): 
 
[root@shed network-scripts]# cat ifcfg-ath0 
DEVICE=ath0 
BOOTPROTO=dhcp 
WIRELESS=yes 
HOTPLUG=yes 
MODE=Managed 
ESSID=((REMOVED)) 
IPV6INIT=no 
ONBOOT=no 
USERCTL=yes 
PEERDNS=yes 
NETMASK=255.255.255.0 
DHCP_HOSTNAME=shed 
IPADDR=192.168.100.3 
DOMAIN= 
HWADDR=00:09:5b:c7:48:3b 
GATEWAY=192.168.100.1 
TYPE=Wireless 
RATE=Auto 
CHANNEL=11 
 
This problem doesn't happen with the eth0 interface - it's specific to the 
wireless interface. 

Version-Release number of selected component (if applicable):
8.11.1-1

How reproducible:
Always

Steps to Reproduce:
1. /sbin/ifup ath0 
   

Actual Results:  IP address obtained, default route not set. 

Expected Results:  Default route set. 

Additional info:

Comment 1 Bill Nottingham 2005-07-12 18:40:08 UTC
What happens if you take the GATEWAY= line out?

Comment 2 David Anderson 2005-07-12 21:07:49 UTC
Yup, that fixes it.  
  
However, if I use system-config-network to switch to using a static IP 
address, and then switch back again to using DHCP, then the line is back (and 
hence the default route from DHCP is not used, which means I get no default 
route). 
 
Worked in FC2, so one of the changes in the meantime will be the cause. 
 

Comment 3 Bill Nottingham 2005-07-12 21:27:30 UTC
I believe the dhclient script was fixed to not set a gateway route if one was
specified; with it in the config file, it appears that one is.

Perhaps s-c-network should take the line out when you switch to a dynamic config?

Comment 4 David Anderson 2005-07-12 21:38:24 UTC
"Perhaps s-c-network should take the line out when you switch to a dynamic  
config?" - I think you're about right. If you switch in s-c-n to "obtain IP 
settings from DHCP" then it ought to mean just that and not "but retain the 
gateway from your previous static IP settings even though they're greyed-out 
and in a different part of the dialogue box".  
However, if you drop the GATEWAY= line then it has to be manually remembered 
and re-entered by the user when he switches back to static settings. (At 
present it's still in there and in s-c-n it's greyed-out in the static IP 
settings part of the dialogue). It would be inconsistent for s-c-n to 
automatically remember two of the static IP settings but not the third.  
  

Comment 5 David Anderson 2005-07-12 21:50:56 UTC
Or perhaps the change in dhclient should be reversed? Or a different parameter 
used for overriding the DHCP-supplied gateway, e.g. DHCP_STATIC_GATEWAY=  or 
OVERRIDE_GATEWAY=YES ?? 

Comment 6 David Anderson 2005-07-13 21:17:11 UTC
This bug appears to be a duplicate of 149780, and the bug is really in s-c-n 
for making a setting that it shouldn't... 

Comment 7 David Anderson 2005-07-13 21:18:47 UTC
Having said that though (#6), the bug can't be fixed just by fixing future 
versions of s-c-n, because there will be people, like me, upgrading from 
previous versions of Fedora Core that have DHCP and GATEWAY=. As the version 
of s-c-n in FC4 still sets BOTH of these, it'll be happenning for a long time 
to come still (e.g. people upgrading from FC4 to FC5 or FC6...). 

Comment 8 Harald Hoyer 2006-05-19 10:31:14 UTC

*** This bug has been marked as a duplicate of 149780 ***


Note You need to log in before you can comment on or make changes to this bug.