Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163029 - Audigy soundcard does not work correctly with alsa-driver 1.0.9-rc2
Summary: Audigy soundcard does not work correctly with alsa-driver 1.0.9-rc2
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-12 12:14 UTC by Christian Nolte
Modified: 2015-01-04 22:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-19 13:54:49 UTC


Attachments (Terms of Use)

Description Christian Nolte 2005-07-12 12:14:06 UTC
Description of problem:

I have an Audigy Player Soundcard and Mic-In and Line-In do not work with
alsa-driver 1.0.9-rc2. See
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=1218 for further details.

Version-Release number of selected component (if applicable):

kernel-2.6.11-1.1369_FC4
kernel-2.6.12-1.1387_FC4
kernel-2.6.12-1.1390_FC4

Advanced Linux Sound Architecture Driver Version 1.0.9rc2

How reproducible:

Install any of the mentioned kernel-packages and see /proc/asound/version. Plug
any soundsource into line-in or mic-in and try to hear the sound.
alsamixer-settings all are unmuted but nothing can be heard.

Comment 1 Dave Jones 2005-07-15 21:45:52 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 2 Christian Nolte 2005-07-16 12:10:54 UTC
This kernel version also has the release-candidate 2 version of alsa-driver
(1.0.9rc2). This should be updated to 1.0.9b. 

Comment 3 Dave Jones 2005-07-19 13:54:49 UTC
If this isn't in 2.6.13 already, the ALSA folks need to get their code merged
there.  There will be a 2.6.13 update fairly quickly after its upstream release,
which should be just a few weeks away.

Fedora kernel policy is that we don't update random drivers to upstream
versions, as it brings a world of problems, which a lot of upstream developers
refuse to debug because the kernel ends up a hybrid of many different codebases.
By staying as close as possible to upstream, we get the benefits of being able
to escalate some bugs to their upstream developers.



Note You need to log in before you can comment on or make changes to this bug.