Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162989 - lvm2 fails to find physical volume with 'pv unknown device' error
Summary: lvm2 fails to find physical volume with 'pv unknown device' error
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm2
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-12 00:24 UTC by Matt Matolcsi
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-15 01:10:55 UTC


Attachments (Terms of Use)

Description Matt Matolcsi 2005-07-12 00:24:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050514 Fedora/1.0.4-0.fdr.1.2 Firefox/1.0.4

Description of problem:
After upgrading to FC4, the LVM2 tools no longer find one of the physical volumes. What is particularly strange is that it does appear to *read* all the physical volumes and correctly reports the UUID of the PV, but it still can't 'see' the device. Here is the attached output of pvscan: 

[root@XXXXXX ~]$ pvscan -uv
    Wiping cache of LVM-capable devices
    Wiping internal VG cache
    Walking through all physical volumes
  Couldn't find device with uuid '24mFHs-KEoS-XC2P-Dciv-i52L-g47V-TCOTK1'.
  PV unknown device with UUID 24mFHs-KEoS-XC2P-Dciv-i52L-g47V-TCOTK1 VG vg0   lvm2 [1.64 TB / 0    free]
  PV /dev/sdd       with UUID WCSlkc-tYFh-hAh3-yglo-VJB7-xrSa-HN6W5X VG vg0   lvm2 [1.64 TB / 0    free]
  Total: 2 [3.27 TB] / in use: 2 [3.27 TB] / in no VG: 0 [0   ]

In other words, it looks like LVM2 is saying "I can't find a device with UUID Z" and "Here is a device with UUID Z" in the same sentence! 

Version-Release number of selected component (if applicable):
lvm2-2.01.08-2.1

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to FC4 from FC3, using 'yum upgrade'. 
2. Reboot the system. 
3.
  

Actual Results:  One of the physical volumes was no longer found; 'pvscan -uv' complains about an 'unknown device' that has the correct UUID, but can't be used for some reason. 

Expected Results:  The PV should've been picked-up and added to the volume group. 

Additional info:

The devices in the volume group are /dev/sda and /dev/sdd. There is a partition table on /dev/sda and a partition defined as /dev/sda1 that spans cylinders 1 to the end of the disk, but the actual physical volume was setup to use /dev/sda as its device (and nothing was ever written to /dev/sda1) as noted in the LVM2 metadata stored on the disk. /dev/sdd comes up without a problem. The disks are accessed over SCSI, using the aic7xxx module.

Comment 1 Matt Matolcsi 2005-07-15 01:10:55 UTC
I think this was a false alert. The problem was that a partition table and boot
loader were installed on /dev/sda as part of an upgrade from FC3->FC4 done via
yum. With those in place, the LVM2 tools would simply not recognize /dev/sda as
an LVM2 volume. 

However, because an upgrade of grub should not have installed the boot loader
into any old convenient location, I will open a new bug report about that (if
one doesn't already exist.)


Note You need to log in before you can comment on or make changes to this bug.