Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162964 - Header-file: missing forward-declaration. Programs using libkexif-devel won't compile
Summary: Header-file: missing forward-declaration. Programs using libkexif-devel won't...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libkexif
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE5Target
TreeView+ depends on / blocked
 
Reported: 2005-07-11 21:17 UTC by Christian Nolte
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 0.2.1-4.fc4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-11 09:40:26 UTC


Attachments (Terms of Use)
Patch which fixes the compile-problem. Can be directly included into SRPM (deleted)
2005-07-11 21:17 UTC, Christian Nolte
no flags Details | Diff

Description Christian Nolte 2005-07-11 21:17:20 UTC
Description of problem:

The File /usr/include/libkexif/kexifdialog.h defines the Class KExifDialog. When
compiling against this file (like for example with digikam-0.7.3), the Class
QComboBox is not known in line 54 of kexifdialog.h. This problem occurs because
no forward-declaration of QComboBox is given.

Perhaps this bug should be forwarded to the implementors of libkexif.

Version-Release number of selected component (if applicable):

libkexif-devel-0.2.1-3

How reproducible:

Include the mentioned header-file into a cpp-file and compile it.
Or compile digikam version 0.7.3 with installed libkexif-devel-0.2.1-3 before
starting configure.

Additional Info:

A patch for the header-file is applied. So it could be integrated into the SRPM
of libkexif.

kdelibs-devel-3.4.1-0
qt-devel-3.3.4-15.1
libkexif-devel-0.2.1-

Comment 1 Christian Nolte 2005-07-11 21:17:20 UTC
Created attachment 116625 [details]
Patch which fixes the compile-problem. Can be directly included into SRPM

Comment 2 Aurelien Bompard 2005-08-11 09:40:26 UTC
Fixed in version 0.2.1-4.fc4, thanks. I contacted upstream, and it's fixed in CVS.


Note You need to log in before you can comment on or make changes to this bug.