Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162962 - rc.sysinit missing section to optimize harddisk params
Summary: rc.sysinit missing section to optimize harddisk params
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 163787 163794 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-11 21:13 UTC by Kevin Blair
Modified: 2014-03-17 02:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-11 21:18:50 UTC


Attachments (Terms of Use)
Block of script from FC3 rc.sysinit (deleted)
2005-07-11 21:19 UTC, Kevin Blair
no flags Details | Diff

Description Kevin Blair 2005-07-11 21:13:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412 (KHTML, like Gecko) Safari/412

Description of problem:
Section to control harddisk params based on files /etc/sysconfig/harddisks and /etc/sysconfig/
harddiskhd[a-t] is missing

Version-Release number of selected component (if applicable):
initscripts-8.11.1-1

How reproducible:
Always

Steps to Reproduce:
Files /etc/sysconfig/harddiskhda /etc/sysconfig/harddisks present with non default params set in them 
  

Actual Results:  no settings sent at boot

Expected Results:  params should have been sent at boot

Additional info:

Comment 1 Bill Nottingham 2005-07-11 21:18:50 UTC
It's intentional; discussions with the kernel people generally stated that
hdparm should not be used.

Comment 2 Kevin Blair 2005-07-11 21:19:06 UTC
Created attachment 116627 [details]
Block of script from FC3 rc.sysinit

Comes just after test block for ide-scsi on command line, and before boot time
profiles

Comment 3 Bill Nottingham 2005-07-21 03:03:41 UTC
*** Bug 163787 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2005-07-21 04:58:14 UTC
*** Bug 163794 has been marked as a duplicate of this bug. ***

Comment 5 jar 2005-07-28 23:28:50 UTC
(In reply to comment #1)
> It's intentional; discussions with the kernel people generally stated that
> hdparm should not be used.

But it should be removed also from /usr/share/doc/initscripts-
8.11.1/sysconfig.txt.

Comment 6 Bill Nottingham 2005-07-29 02:25:32 UTC
Removed in CVS, will be in 8.12-1.

Comment 7 Doncho Gunchev 2005-09-25 18:58:40 UTC
    Does this mean that we should open bug reports against the kernel package in
cases like hdparm -t gives 12MB/sec without tweaking and 52MB/sec with (or 12 vs
22 on my laptop) without DMA timeouts/errors? What info should we provide?

Comment 8 Bill Nottingham 2005-09-26 16:17:43 UTC
Yes. Probably you'd need at least IDE chipset type (lspci -v), the hdparm info
for  what it's currently set at, the dmesg output of it setting up the
controller, and the drive information & topography (what's on what channel, as
master, slave, etc.)

Comment 9 Peter Bieringer 2006-04-30 10:26:34 UTC
Can one please tell me how to specify now power saving for IDE harddisk drives
to save power (think about energy consumption and energy saving) by an easy way?

In BIOS, I can only set max. 15 minutes, but this value is only applied to the
first and second IDE channel. 3rd and 4th are not set.

So I find it was not a good idea to remove the /etc/sysconfig/harddisks support
in rc.sysinit.

I've never heard about a config switch in kernel to specify IDE sleep values.
For example, I use "-S 240".

BTW: it's also not a very good idea to put all the IDE issues coming now up back
to kernel maintainers, the turnaround times are too long for quick
enabling/disabling of default parameters (like e.g. DMA off for broken drives).

Looks like now rc.local has to be used for that, imho, that's not a step
forewards, it's a step backwards.



Comment 10 Peter Bieringer 2006-04-30 11:09:18 UTC
Here an example for rc.local:

for entry in /proc/ide/h*; do drive=`basename $entry`; hdparm -S 240
/dev/$drive; done

BTW: don't forget a proper configuration for smartd to prevent wakeup of IDE drives.
/dev/hdg -H -n standby -o off
/dev/hdc -H -n standby -o off
/dev/hde -H -n standby -o off


Comment 11 Bill Nottingham 2006-05-01 17:34:00 UTC
KERNEL=="hd[a-z]", BUS=="ide", SYSFS{removable}=="0", RUN+="hdparm -S 240 /dev/%k"

or something similar in a udev rules file should do the trick.


Comment 12 Peter Bieringer 2006-05-02 10:32:20 UTC
Thank you for that hint, interesting, because of SYSFS{removable}=="0" only real
IDE harddisks will get the powersave parameter.

Looks like to me it would be time to extend udev to use a boolean file like in
SELinux to enable conditial rules and perhaps retrieve from config file also a
special parameter.

E.g.
/etc/udev/udev.conf:
udev_bool_ide_harddisks_powersave=1 -> enables conditional udev rule
udev_value_ide_harddisks_powersave_value=240 -> parameter for hdparm


Note You need to log in before you can comment on or make changes to this bug.