Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162958 - Removing [homes] section of the smb.conf causes a segfault.
Summary: Removing [homes] section of the smb.conf causes a segfault.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Simo Sorce
QA Contact: David Lawrence
URL: https://bugzilla.samba.org/show_bug.c...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-11 20:42 UTC by Johnny Hughes
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-28 20:08:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Samba Project 1983 None None None Never

Description Johnny Hughes 2005-07-11 20:42:38 UTC
Description of problem:  Removing [homes] section of the smb.conf causes a segfault.


Version-Release number of selected component (if applicable):  samba-3.0.10-1.4E


How reproducible:  Always


This bug describes the problem.  It is supposedly fixed in samba-3.0.11.

https://bugzilla.samba.org/show_bug.cgi?id=1983

Comment 1 RHEL Product and Program Management 2006-08-18 17:33:57 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Nalin Dahyabhai 2006-08-29 18:18:26 UTC
Can you provide some more detail on how to trigger the segfault?  It's not
immediately obvious to me how this can be done, as removing the section and
either restarting or reloading the 'smb' service didn't cause any problems on my
tests setup, even for subsequent connection requests.


Comment 4 Kevin Krafthefer 2007-03-28 20:08:25 UTC
The requested information never came in for a resolution to be arrived at. We
are unable to reproduce here at Red Hat. Please reopen this bug if you can
provide the requested information.


Note You need to log in before you can comment on or make changes to this bug.