Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162941 - 'Top' utility doesn't save configuration file '.toprc' correctly
Summary: 'Top' utility doesn't save configuration file '.toprc' correctly
Keywords:
Status: CLOSED DUPLICATE of bug 161449
Alias: None
Product: Fedora
Classification: Fedora
Component: procps
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Brian Brock
URL: http://download.fedora.redhat.com/pub...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-11 18:50 UTC by Niksa Jurinovic
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-11 20:16:08 UTC


Attachments (Terms of Use)

Description Niksa Jurinovic 2005-07-11 18:50:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; .NET CLR 1.1.4322)

Description of problem:
`top` utility from procps doesn't function correctly. When window colors are changed, pressing 'W' doesn't save configuration file (.toprc) correctly, so the next time the top is started, the old black-and-white screen always appears (as if nothing were changed). Examining .toprc config file, it can be seen that labels on the left side are missing (Def, Job, ...). 


Version-Release number of selected component (if applicable):
procps-3.2.5-6.i386.rpm 

How reproducible:
Always

Steps to Reproduce:
1. Start top
2. Change the window colors
3. Press 'W' to save configuration file. Configuration file is saved (but not correctly). Restart the top utility. 
  

Actual Results:  Black-and-white screen appears as if nothing were changed.


Expected Results:  Colored window must appear.

Additional info:

This may be interesting: RHEL-4 AS 'procps' binary rpm package works OK on FC4. But, when source RHEL-4 'procps' rpm package is rebuilt on FC4, rebuilt 'top' works just as FC4 'top' (doesn't save .toprc correctly).

Comment 1 Karel Zak 2005-07-11 20:16:08 UTC

*** This bug has been marked as a duplicate of 161449 ***


Note You need to log in before you can comment on or make changes to this bug.