Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162923 - evolution crashes every time it is started on rawhide
Summary: evolution crashes every time it is started on rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-11 17:40 UTC by Tom Duffy
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-29 18:56:17 UTC


Attachments (Terms of Use)

Description Tom Duffy 2005-07-11 17:40:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
After upgrading to rawhide today (7/11/05), evolution will not start.  It crashes every time with the following backtrace (taken from bug buddy):

Backtrace was generated from '/usr/bin/evolution'

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46912534259696 (LWP 6231)]
[New Thread 1074006368 (LWP 6303)]
0x00002aaaab548fa9 in waitpid () from /lib64/libpthread.so.0
#0  0x00002aaaab548fa9 in waitpid () from /lib64/libpthread.so.0
#1  0x0000003fc7d4f15c in libgnomeui_segv_handle (signum=11)
    at gnome-ui-init.c:741
#2  <signal handler called>
#3  0x0000003fc8e41d37 in e_canvas_hide_tooltip ()
   from /usr/lib64/libgal-2.4.so.0
#4  0x0000003fc8e70ddb in e_table_item_get_printable ()
   from /usr/lib64/libgal-2.4.so.0
#5  0x00002aaaaba95749 in IA__g_object_unref (_object=) at gobject.c:565
#6  0x0000003fc8e6964f in e_table_group_leaf_get_type ()
   from /usr/lib64/libgal-2.4.so.0
#7  0x00002aaaaba96056 in IA__g_object_run_dispose (object=0x85ea70)
    at gobject.c:610
#8  0x0000003fc8e88d9a in e_table_new_from_spec_file ()
   from /usr/lib64/libgal-2.4.so.0
#9  0x00002aaaabdf3fde in IA__g_main_context_dispatch (context=0x5687f0)
    at gmain.c:1934
#10 0x00002aaaabdf6c74 in g_main_context_iterate (context=0x5687f0, block=1, 
    dispatch=1, self=) at gmain.c:2565
#11 0x00002aaaabdf7160 in IA__g_main_loop_run (loop=0x696040) at gmain.c:2769
#12 0x0000003b00a2d3bb in bonobo_main () from /usr/lib64/libbonobo-2.so.0
#13 0x000000000041b56a in main (argc=) at main.c:610

Thread 2 (Thread 1074006368 (LWP 6303)):
#0  0x00002aaaac416d50 in poll () from /lib64/libc.so.6
No symbol table info available.
#1  0x00002aaaabdf6b8f in g_main_context_iterate (context=0x87f290, block=1, 
    dispatch=1, self=) at gmain.c:2867
	max_priority = 2147483647
	timeout = -1
	some_ready = 
Thread 1 (Thread 46912534259696 (LWP 6231)):
#0  0x00002aaaab548fa9 in waitpid () from /lib64/libpthread.so.0
No symbol table info available.
#1  0x0000003fc7d4f15c in libgnomeui_segv_handle (signum=11)
    at gnome-ui-init.c:741
	estatus = 0
	in_segv = 1
	sa = {__sigaction_handler = {sa_handler = 0, sa_sigaction = 0}, 
  sa_mask = {__val = {0, 0, 46912512858703, 46912524293760, 140737486182688, 
      9150880, 7184590863, 140737486182832, 140737486182784, 140737486183120, 
      0, 10308976, 128, 5505040, 0, 5504896}}, sa_flags = 0, 
  sa_restorer = 0x2008ba1a0}
	pid = 

Version-Release number of selected component (if applicable):
evolution-2.2.2-11.fc5

How reproducible:
Always

Steps to Reproduce:
1. upgrade machine to latest rawhide
2. run evolution
3.
  

Additional info:

Comment 1 Tom Duffy 2005-07-11 19:36:28 UTC
after some further investigation, this seems to be happening if evolution is
trying to start with anything *other* than mail.  I am able to get mail to start
by issuing the command:

$ evolution --component=mail



Comment 2 Lars G 2005-07-13 13:19:15 UTC
same here

Comment 3 Tom Duffy 2005-07-29 18:13:43 UTC
this seems to be fixed by chance in latest evolution-2.3.6-1.  should I close?

Comment 4 Dave Malcolm 2005-07-29 18:56:17 UTC
Looks like a problem with libgal2, which should now be fixed.

Good to hear that it's working for you now; I'm going to close this one.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.