Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162917 - Radeon 9200 (Mac Ed) only works with fbdev
Summary: Radeon 9200 (Mac Ed) only works with fbdev
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL: http://www.pdc.kth.se/~mike/ppc/Bunny/
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-11 17:07 UTC by Mike Hammill
Modified: 2008-08-02 23:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-03 18:22:07 UTC


Attachments (Terms of Use)

Description Mike Hammill 2005-07-11 17:07:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412 (KHTML, like Gecko) Safari/412

Description of problem:
Basically, I cannot use any of the capabilities of my Radeon 9200 (Mac Ed) graphics card under Rawhide 
PPC.  I can only use it as a fbdev.  This was also true for FC3 and FC4 and is one of the main reasons I 
tried Rawhide.  However, I know the Radeon 9200 Mac Edition can be supported successfully under 
xorg and Linux, since it works on a Ubuntu distro I run.  I hope you can make it run under Fedora/
Redhat as well.

For the sake of bugzilla, I copy the content of the problem, as discussed at <http://lists.infradead.org/
pipermail/fedora-ppc/2005-July/000574.html> here:

I have a machine similar to J.M. Brough, a G4 PowerMac with an ATI  
Radeon 9200 PCI card in it.

I updated my card's ROM through the software available at ATI so mine  
reads (from the Mac OS X partition):

ATI 4.5.1 Radeon 9200
Card#:  109-actually gives numbers here-00
Card Model: ATY, RV280
ROM: ATY, Bugsy_A
FCode version: 1.94
NDRV version: 1.0.1f59
VRAM: 128MB

I installed the Xautoconfig tool from <http://www.bytebot.net/geekdocs/ibook/fedorappc.html> as 
you suggest.  I tried various  
options, and got the following results:

with --safe option ==> an X cursor on a black screen.  I can move the  
cursor, but I when I right click, I get no menu.  This is the best  
I've got so far.  X log at <http://www.pdc.kth.se/~mike/ppc/Bunny/Xorg_log_xautoconfig_safe>.  It is 
not clear to me that this  
configuration is usable as is.

with --fbdev option ==> as above, log at <http://www.pdc.kth.se/~mike/ppc/Bunny/
Xorg_log_xautoconfig_fbdev>

with no options ==> dies with log as shown in <http://www.pdc.kth.se/~mike/ppc/Bunny/
Xorg_log_xautoconfig_noopts>

I brought over a working xorg.conf from Ubuntu running on another G4  
with the same card in it.  See <http://www.pdc.kth.se/~mike/ppc/Monkey/xorg.conf> and the happy 
log it produces on Ubuntu <http://www.pdc.kth.se/~mike/ppc/Monkey/Xorg.0.log>

When I try this xorg.conf under Fedora rawhide, it bombs see log at  
<http://www.pdc.kth.se/~mike/ppc/Bunny/Xorg_log_ubuntu_working>.  A  
careful analysis of the working X log on the one machine and the  
failing log on the other should give a pretty good hint as to what is  
wrong, I suspect.  A simple diff, unfortunately, is a bit messy.  I  
haven't had a chance to look through the two logs extensively to get  
at what the real differences are.  Perhaps someone with more X  
knowledge could give it a whirl?

/Mike


Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-40

How reproducible:
Always

Steps to Reproduce:
1. Using a working xorg.conf file from Ubuntu I try to startx using Fedora rawhide.  X fails to start (with 
messages as show at given URLs).
2. Using a X config file generated by Xautoconfig --safe or --fbdev, X works, though at a really poor 
resolution
  

Actual Results:  Error messages and failed X

Expected Results:  Nice X11 starting.

Additional info:

Please see attached URLs which point to the important details.  If you want these files inserted in their 
entirety into bugzilla, let me know.

Other similar bugs I saw in bugzilla, but which were not quite close enough to simply add to, were:
121051 (radeon se card)
134967 (dual head--I am only trying to get one head working now)
162874 (radeon pro card)

Comment 1 Mike A. Harris 2005-08-30 14:47:52 UTC
The main problem IIRC, is that the IBM pSeries/iSeries machines need to
be configured one way, but Macs need to be configured a different way, and
you have to have things configured correct for the machine you're using.

Our PPC development started out for IBM PPC servers, and so our config
tools and whatnot assume IBM hardware and set it up accordingly as this
is what is desired for Red Hat Enterprise Linux.

However...  now we are doing Fedora for PPC too, and this is not good for
Fedora/PPC users who are mostly if not entirely Mac users.  We really do
need a solution that not only works for both systems, but preferably can
detect wether the given PPC box is IBM or Apple, and act accordingly.

I discussed this with someone before, perhaps Jeremy... I don't recall
exactly.  I was pretty sure that someone had already changed our tools
to handle this properly, so that Macs get configured correctly.  If not,
then we still have a config tool issue that needs to get ironed out.

Reassigning to system-config-display, as I believe that is where the
decision gets made.  Please reassign to pyx*config or whatever if
that's more appropriate.



Comment 2 Adam Jackson 2007-01-29 23:57:44 UTC
This ought to be working now, the main problem with the old method was that
pSeries wanted fbdev because the mga driver wouldn't work (due to 64-bit PCI bus
shenanigans).  Please reopen if this issue still occurs for you on FC6 or newer.

Comment 3 Adam Jackson 2007-04-03 18:22:07 UTC
NEEDINFO timeout, resolving as INSUFFICIENT_DATA.  If you are still experiencing
this bug in FC6 or FC7, please reopen.  Thanks for the report!


Note You need to log in before you can comment on or make changes to this bug.