Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162911 - Booting hangs on Radeon 9200 unless "debug" used
Summary: Booting hangs on Radeon 9200 unless "debug" used
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Brian Brock
URL: http://lists.infradead.org/pipermail/...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-11 16:34 UTC by Mike Hammill
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-06 07:08:49 UTC


Attachments (Terms of Use)

Description Mike Hammill 2005-07-11 16:34:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/412 (KHTML, like Gecko) Safari/412

Description of problem:
Directly after the penguin image appears during boot up, I get the one-line message:

"PCI: Cannot allocate resource region 1 of device 0001:11:02.0"

Then the bootup sequence hangs.  I get this with both Kernel 2.6.11-1.1381_FC5 and 
2.6.12-1.1411_FC5.  I did not received this message with the 2.6.11-1.1381_FC5 kernel until I updated 
my graphics card's ROM.  (The 2.6.12 kernel was not out at the time.)  The graphics in questions is a 
Radeon 9200 (Mac Edition).  I updated my ROM to the latest version from the ATI site using a Mac OS X 
partition on the same machine.  The ROM is now at: ATI 4.5.1, ROM ATY, Bugsy_A, FCode version 1.94, 
NDRV version 1.0.1f59.

The only way around the problem is to add the "debug" kernel option.  Using just "text" will not do it.  
Also, using "video=radeonfb" or "video=ofonly" does not work, unless "debug" is also appended as a 
Kernel option.

Related to this problem, I have not been able to run X with "ati" and "radeon" drivers, but only with 
fbdev.  Too bad, since the same card in a slightly different model of Mac (both are PowerMac G4s) 
works with X using the Ubuntu distribution.  Gentoo 2005.0 installation CD gives exactly the same error 
message, so I'm assuming it's a common kernel thing.

A few more details are at the above URL.



Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1411_FC5 and 2.6.11-1.1381_FC5

How reproducible:
Always

Steps to Reproduce:
1.  Boot up machine.  At yaboot boot loader pick linux (as opposed to Mac OS)
2.  Choose a rawhide kernel 2.6.12-1.1411_FC5 or 2.6.11-1.1381_FC5 (only two I have) but do not 
include the "debug" option.

  

Actual Results:  Penguin image appears, followed by the one-line message:

"PCI: Cannot allocate resource region 1 of device 0001:11:02.0"

After that, the machine hangs indefinitely.

Expected Results:  Boot sequence should proceed.

Additional info:

Output of dmesg when using the above mentioned Kernel 2.6.12 and options "video=radeonfb debug" 
is at:
http://www.pdc.kth.se/~mike/ppc/Bunny/dmesg_video_radeon_debug_2_6_12

Above mentioned forum text "Request for Testing of Installer X Configuration on PPC" at:
http://lists.infradead.org/pipermail/fedora-ppc/2005-July/000573.html

Additional forum text "Failed X server start on Apple eMac FC4 installation" at:
http://lists.infradead.org/pipermail/fedora-ppc/2005-July/000574.html

Comment 1 Dave Jones 2005-08-26 04:44:27 UTC
still a problem with latest build ?



Note You need to log in before you can comment on or make changes to this bug.