Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162892 - courier-imap folder prefix settings wrong
Summary: courier-imap folder prefix settings wrong
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: squirrelmail
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-11 13:16 UTC by Alexander Broekhuis
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-11 13:44:40 UTC


Attachments (Terms of Use)

Description Alexander Broekhuis 2005-07-11 13:16:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
If i try to configure squirrelmail with courier-imap (installed from source) a cannot create maildir error is given when logged in to squirrelmail. Squirrelmail in configured using the default courier-imap settings that are supplied by squirrelmail.

This error happens because the fedora squirrelmail installation overrides the default_folder_prefix to make squirrelmail work with dovecot. Removing the overridden prefix makes it work.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install and configure courier-imap
2.Install and configure squirrelmail to use courier-imap
3.Login to squirrelmail 
  

Actual Results:  The mail overview is shown, the folders overview not.

Additional info:

Squirrelmail 1.5 has default settings for dovecot that can be selected during squirrelmail configuration. Perhaps it is possible to backport these changes?

Comment 1 Warren Togami 2005-07-11 13:44:40 UTC
We can't have it both ways.  We had to set it to our preferred IMAP server,
which is dovecot.  Sorry if this inconveniences you, but you can easily fix it
for your own install.

Comment 2 Alexander Broekhuis 2005-07-11 14:04:01 UTC
Setting it to the preferred IMAP server makes sense, but what about using the
squirrelmail 1.5 settings for dovecot? That way there is no need for the
overridden configuration file. Selecting the correct imap server isn't a problem
at all.

Or am I missing something in my assumptions?

Comment 3 Warren Togami 2005-07-11 14:16:55 UTC
We ship it so it requires no configuration to work with our preferred IMAP
server, which we also ship.  We do not ship courier-imap anymore in Core, but
you are free to download it from Extras and reconfigure squirrelmail to use it.

However...  Bug #162568 indicates that you probably don't want to use FC4
squirrelmail at all since it is incompatible with the PHP.  We can't ship the
unstable CVS version in the distribution, so we're stuck at the moment with no
options here.

Comment 4 Alexander Broekhuis 2005-07-11 14:31:33 UTC
OK thx for the info. Concerning bug 162568, i did not yet find any problems. But
i'm setting up a new system, so did not test it very good yet.

I do hope the 1.5 version will be released any time soon... been in development
for over a year now :(.

Again thx for the quick replies.


Note You need to log in before you can comment on or make changes to this bug.