Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162889 - yum-builddep does not check for root user access
Summary: yum-builddep does not check for root user access
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-11 10:44 UTC by Rahul Sundaram
Modified: 2013-03-13 05:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-12-26 11:58:12 UTC


Attachments (Terms of Use)

Description Rahul Sundaram 2005-07-11 10:44:57 UTC
Description of problem:

yum-builddep does not check for root user access

Version-Release number of selected component (if applicable):
yum-utils-0.2-2.fc4

How reproducible:

Everytime

Steps to Reproduce:

run yum-builddep <package> ex: gnome-utils as non-root user
  
Actual results:

yum-builddep gnome-utils
Setting up repositories
Traceback (most recent call last):
  File "/usr/bin/yum-builddep", line 69, in ?
    main(sys.argv[1:])
  File "/usr/bin/yum-builddep", line 32, in main
    base.doRepoSetup(dosack=0)
  File "/usr/share/yum-cli/cli.py", line 71, in doRepoSetup
    yum.YumBase.doRepoSetup(self, thisrepo=thisrepo)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 233, in doRepoSetup
    repo.getRepoXML(text=repo)
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 649, in getRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 619, in get
    http_headers=headers,
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 414, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 400, in
_mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 618, in
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 547, in _retry
    return apply(func, (opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 606, in
retryfunc
    fo._do_grab()
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 916, in
_do_grab
    else: new_fo = open(self.filename, 'wb')
IOError: [Errno 13] Permission denied: '//var/cache/yum/development/repomd.xml'


Expected results:

yum produces the following output when run as non-root user. utilities within
yum-utils should do the same

"You need to be root to perform this command

Comment 1 Tim Lauridsen 2006-09-18 07:47:03 UTC
Looks like this one can be closed, the current yum-builddep contains a root user
check.


Note You need to log in before you can comment on or make changes to this bug.