Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162886 - Autofs-related kernel panic
Summary: Autofs-related kernel panic
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jeff Moyer
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-11 09:07 UTC by Trond H. Amundsen
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: kernel-2.6.9-34.EL
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-18 13:22:16 UTC


Attachments (Terms of Use)
Console messages during panic (deleted)
2005-07-11 09:07 UTC, Trond H. Amundsen
no flags Details
/etc/auto.master (deleted)
2005-07-25 13:01 UTC, Trond H. Amundsen
no flags Details
Contents of /etc/auto.d/ (deleted)
2005-07-25 13:02 UTC, Trond H. Amundsen
no flags Details
Output from mount. (deleted)
2005-10-24 13:09 UTC, Trond H. Amundsen
no flags Details

Description Trond H. Amundsen 2005-07-11 09:07:21 UTC
Description of problem:
Machine panicked during seemingly normal operation, but I can't be sure since
this is a general login server and had ~100 users logged in at the time. The
panic appears to be related to autofs. This particular machine relies heavily on
autofs, mounting several hundreds of filesystems from a large number of NFS
servers around campus, mostly Solaris, HP-UX and Linux. The output (grabbed from
serial console) is attached.

Version-Release number of selected component (if applicable):
2.6.9-11.ELsmp

How reproducible:
Unknown. It's the first time I've seen this.

Comment 1 Trond H. Amundsen 2005-07-11 09:07:21 UTC
Created attachment 116591 [details]
Console messages during panic

Comment 2 Jeff Moyer 2005-07-22 23:14:22 UTC
Looks like a recursive lookup of some sort.  Is this problem reproducable at all?

Could you please provide the information requested under the section "Filing bug
reports" on the following web page?

  http://people.redhat.com/jmoyer

Thanks.

Comment 3 Trond H. Amundsen 2005-07-25 13:00:12 UTC
Sure, her it is:

 - autofs version: autofs-4.1.3-131
 - kernel version: 2.6.9-11.ELsmp

I'll attach the contents of auto.master and the maps.

Debug logging with syslog seems to create large files very fast, so I've
disabled that for now. I don't know how to reproduce the panic anyway..

Comment 4 Trond H. Amundsen 2005-07-25 13:01:30 UTC
Created attachment 117118 [details]
/etc/auto.master

Comment 5 Trond H. Amundsen 2005-07-25 13:02:15 UTC
Created attachment 117119 [details]
Contents of /etc/auto.d/

Comment 6 Jeff Moyer 2005-09-15 14:18:17 UTC
This looks very much like a problem that was encountered when doing bind mounts.
 Are there any bind mounts in your setup?  Can you post the output of 'mount'
for your setup?

I have a patch that should address this issue.  Is this easily reproducable?

Comment 7 Jeff Moyer 2005-10-21 15:32:02 UTC
I'm still waiting for answers to the above questions.  Could you provide an
update, please?

Comment 8 Trond H. Amundsen 2005-10-24 13:04:04 UTC
Sorry for the late reply. No, there aren't any bind mounts, and I'll attach the
output from 'mount'. I have seen this problem only once, and have no idea how to
reproduce it, since I don't know what triggered it in the first place.

Comment 9 Trond H. Amundsen 2005-10-24 13:09:15 UTC
Created attachment 120305 [details]
Output from mount.

Note that the autofs setup has been changed slightly since I attached
the autofs maps, as new disks are mounted.

Comment 10 Jeff Moyer 2006-04-17 19:19:10 UTC
Have you seen this problem again?  I really think that it was fixed in kernel
version 2.6.9-22.6.  Without debug logs, I'll be unable to diagnose this
exactly.  Could you at least try the U3 kernel (2.6.9-34.EL) and let me know if
it resolves the problem for you?

Thanks!

Comment 11 Trond H. Amundsen 2006-04-18 12:39:01 UTC
I have not seen the problem again. Only once. But I'll install the latest kernel
anyway and let you know if it happens again. I think it's safe to close this bug
for now. I'll reopen it if I ever see this problem again. Thanks Jeff.


Comment 12 Jeff Moyer 2006-04-18 13:22:16 UTC
OK, thanks!


Note You need to log in before you can comment on or make changes to this bug.