Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162885 - svn requires libcom_err.so.3 (not provided as dependency)
Summary: svn requires libcom_err.so.3 (not provided as dependency)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: subversion
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-11 09:00 UTC by Bastien Miras
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-18 21:21:41 UTC


Attachments (Terms of Use)

Description Bastien Miras 2005-07-11 09:00:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
The svn binary provided by the FC3 package subversion-1.1.4-1.1.i386.rpm seems to have been linked with libcom_err.so.3.
# ldd /usr/bin/svn
...
libcom_err.so.3 => not found
...

 This library doesn't come with the dependencies. I was not able to find libcom_err.so.3 in the whole FC3 archive.

Version-Release number of selected component (if applicable):
subversion-1.1.4-1.1.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Download libcom_err.so.3 at http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/i386/subversion-1.1.4-1.1.i386.rpm
2. install the rpm: 
# rpm -i subversion-1.1.4-1.1.i386.rpm
3. check needed libraries:
#  ldd /usr/bin/svn
  

Actual Results:  I get:
 libcom_err.so.3 => not found 

Expected Results:  I expect:
 libcom_err.so.3 => /usr/lib/libcom_err.so.3 

Additional info:

Comment 1 Joe Orton 2005-07-18 21:21:41 UTC
You probably have third-party or outdated packages (perhaps apr, apr-util) on
your system.  Try a complete "yum update".

Comment 2 Bastien Miras 2005-07-19 08:00:49 UTC
(In reply to comment #1)
> You probably have third-party or outdated packages (perhaps apr, apr-util) on
> your system.  Try a complete "yum update".

My system is up to date I have done:
yum update with no changes.

My version are:
apr-0.9.4-24.2
apr-util-0.9.4-17
It seems to be the last versions.

This doesn't explain to me in which package libcom_err.so.3 is since it is
needed by subversion-1.1.4-1.1.i386.rpm
For me the bug is still open.


Comment 3 Bastien Miras 2005-07-19 08:28:39 UTC
(In reply to comment #1)
> You probably have third-party or outdated packages (perhaps apr, apr-util) on
> your system.  Try a complete "yum update".

Ok I have check my system, I used third party library that's why I got the problem,
The problem is my side
thank you for you answer.


Note You need to log in before you can comment on or make changes to this bug.