Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162884 - system-config-services gives warning box with no text when adding a non-existent service
Summary: system-config-services gives warning box with no text when adding a non-exist...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-services
Version: 4
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-11 07:23 UTC by David Costanzo
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-16 16:10:45 UTC


Attachments (Terms of Use)
Screenshot-Warning.png -- Screenshot of warning with no text (deleted)
2005-07-11 07:24 UTC, David Costanzo
no flags Details

Description David Costanzo 2005-07-11 07:23:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050531 Firefox/1.0+

Description of problem:
system-config-services has a menu option for adding a new services under "Actions - Add Service".  If you give it the name of a service that does not exist on the system (for example, because it is not installed), you get a strange-looking warning box that has no text.


Version-Release number of selected component (if applicable):
system-config-services-0.8.25-1

How reproducible:
Always

Steps to Reproduce:
1. Start system-config-services
2. Select Action - Add Service.  This displays an "Add Service" dialog box.
3. Enter "nonexistent" in the "Service Name" field and press OK.


Actual Results:  A strange looking warning box is displayed.  This box has no text in it.

Expected Results:  An informative warning box is displayed that says something like:

  The service could not be added because it is not installed.

Or:

  The service could not be added because it could not be found.


Additional info:

I encountered this when attempted to add a cvs pserver to my system.  My system did not have xinetd installed, and I attempted to add it as a service.  I saw the warning box, and knew *something* was wrong (which is good), but I wasn't sure exactly what went wrong (which is room for improvement).  Eventually, I figured out that I didn't have xindetd's RPM installed, even though I had /etc/xinetd.d/cvs.  A more informative error message may helped me figure out my problem sooner (but we're only talking about fifteen minutes of head-scratching).

I have given this a severity of "low" instead of "feature enhancement" because this feels like a bug, not a feature that was cut.

Comment 1 David Costanzo 2005-07-11 07:24:43 UTC
Created attachment 116582 [details]
Screenshot-Warning.png -- Screenshot of warning with no text

Comment 2 Nils Philippsen 2005-08-16 13:01:26 UTC
fixed in CVS

Comment 3 Nils Philippsen 2005-08-16 16:10:45 UTC
should be fixed in 0.8.26


Note You need to log in before you can comment on or make changes to this bug.