Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162879 - CD drive not mountable
Summary: CD drive not mountable
Keywords:
Status: CLOSED DUPLICATE of bug 162347
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-11 04:15 UTC by Geraldo Veiga
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-12 22:08:31 UTC


Attachments (Terms of Use)

Description Geraldo Veiga 2005-07-11 04:15:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I am running FC4 on a Dell Inspiron 8100 with a SAMSUNG CD-ROM SN-124
CD Drive cannot be mounted.  Loading an Audio CD causes a system crash.  I had already observed this problem in some kernel releases of FC3.

After loading a data CD-ROM the following messages are generated:

Jul 11 00:53:57 ggv-win32 kernel: hdb: status error: status=0x58 { DriveReady SeekComplete DataRequest }
Jul 11 00:53:57 ggv-win32 kernel: ide: failed opcode was: unknown
Jul 11 00:53:57 ggv-win32 kernel: hdb: drive not ready for command
Jul 11 00:53:58 ggv-win32 kernel: hdb: status error: status=0x7f { DriveReady DeviceFault SeekComplete DataRequest CorrectedError Index Error }
Jul 11 00:53:58 ggv-win32 kernel: hdb: status error: error=0x7f { IllegalLengthIndication EndOfMedia AbortedCommand MediaChangeRequested LastFailedSense=0x07 }
Jul 11 00:53:58 ggv-win32 kernel: ide: failed opcode was: unknown
Jul 11 00:53:58 ggv-win32 kernel: hdb: DMA disabled
Jul 11 00:53:58 ggv-win32 kernel: hdb: drive not ready for command
Jul 11 00:53:58 ggv-win32 kernel: hdb: ATAPI reset complete
Jul 11 00:53:58 ggv-win32 kernel: hdb: status error: status=0x7f { DriveReady DeviceFault SeekComplete DataRequest CorrectedError Index Error }


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1390_FC4 and kernel-2.6.12-1.1387_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot system
2. Load CD-ROM
3. Examine /var/log/messages
  

Actual Results:  CD-ROM was not automatically mounted.

If I try to open it manually with

mount /dev/hdb  /media/cdrom -t iso9660

The resualt is the following:mount: block device /dev/hdb is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hdb,
       missing codepage or other error
       (could this be the IDE device where you in fact use
       ide-scsi so that sr0 or sda or so is needed?)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so





Additional info:

Comment 1 Dan Carpenter 2005-07-11 05:39:17 UTC
That really looks like a bad CDROM.  Do you have any different CDROMs to test with?



Comment 2 Geraldo Veiga 2005-07-11 17:55:12 UTC
It started working again after a few days.  You could be right. It had happened
before (with FC3 kernels) and I associated the event with kernel updades.  

The reasons I am not just saying  "never mind" are:

1. Even during the downtime under FC, it still worked under Windows XP.

2. Loading an audio CD  would freeze the system.

During the boot process, there is still a funny message:

Jul 11 12:57:29 ggv-win32 kernel: ide-cd: cmd 0x28 timed out
Jul 11 12:57:29 ggv-win32 kernel: hdb: DMA interrupt recovery
Jul 11 12:57:29 ggv-win32 kernel: hdb: lost interrupt
Jul 11 12:57:29 ggv-win32 kernel: hdb: status error: status=0x58 { DriveReady
SeekComplete DataRequest }
Jul 11 12:57:29 ggv-win32 kernel: ide: failed opcode was: unknown
Jul 11 12:57:29 ggv-win32 kernel: hdb: drive not ready for command
Jul 11 12:57:29 ggv-win32 kernel: hdb: status timeout: status=0xd0 { Busy }
Jul 11 12:57:29 ggv-win32 kernel: ide: failed opcode was: unknown
Jul 11 12:57:29 ggv-win32 kernel: hdb: DMA disabled
Jul 11 12:57:29 ggv-win32 kernel: hdb: drive not ready for command
Jul 11 12:57:29 ggv-win32 kernel: hdb: ATAPI reset complete

Comment 3 Dave Jones 2005-07-12 22:08:31 UTC

*** This bug has been marked as a duplicate of 162347 ***


Note You need to log in before you can comment on or make changes to this bug.