Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162865 - unpredictable freezes in FC4 x86_64
Summary: unpredictable freezes in FC4 x86_64
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-10 19:55 UTC by Adam Goodman
Modified: 2015-01-04 22:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-26 08:52:55 UTC


Attachments (Terms of Use)

Description Adam Goodman 2005-07-10 19:55:00 UTC
Description of problem:

After installing the x86_64 version of FC4 (and FC3, for that matter) on my
computer, the system freezes unpredictably, though in most cases, it does not
take more than an hour for such a freeze to occur after the system is booted.
I've only had this occur when using X (but I don't generally spend much time in
the console); it does not, however, matter which video driver I use - this has
happened with the default 'radeon', ATI's proprietary drivers, and even the vesa
driver. When the system freezes, it freezes completely - I cannot switch to a
console, kill the X server, etc.

I tried to look in the logs in /var/log near the time of the freezes, but found
nothing, however, I might not know where to look.

Except when I tried to use ATI's drivers (fglrx), I was not using anything other
than what is included in FC4. 

This does not happen if I use the i686 version of either distribution.

My System:
Motherboard: Chaintech VNF3-250
CPU: Socket 754 Athlon 64 3200+
RAM: 1GB PC2700 DDR
Video Card: Sapphire ATI Radeon 9600 XT
Audio: NForce3 onboard audio using snd-intel8x0 driver
Other Hardware: Leadtek Winfast 2000XP deluxe tv tuner card (uses bttv)

How reproducible:
I cannot reproduce this problem predictably, except that I've never run my
system for more than a few hours without this happening.

Additional info:
My symptoms seem to be identical to those reported in bug 161328, but they are
not caused by a proprietary video driver.

Comment 1 Dave Jones 2005-07-15 21:03:19 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 2 Dave Jones 2005-08-26 08:52:55 UTC
There's not a great deal of info to go on here unfortunatly, though given you've
tried various different drivers, it smells like a hardware problem.

I recommend reading http://www.livejournal.com/users/kernelslacker/16552.html

unless you manage to capture a kernel panic with a serial console, there's not a
lot I can do about this bug.



Note You need to log in before you can comment on or make changes to this bug.