Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162862 - RPM_OPT_FLAGS -m64 -mtune=nocona not valid for gcc32
Summary: RPM_OPT_FLAGS -m64 -mtune=nocona not valid for gcc32
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-10 19:06 UTC by Adam Pribyl
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-13 18:04:31 UTC


Attachments (Terms of Use)

Description Adam Pribyl 2005-07-10 19:06:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050511

Description of problem:
File /usr/lib/rpm/redhat/rpmrc specifies RPM_OPT_FLAGS for x86_64 like:
optflags: x86_64 %{__global_cflags} -m64 -mtune=nocona

-mtune=nocona is however not valid for cc1 when gcc32 is used for compilation on this platform.

Version-Release number of selected component (if applicable):
redhat-rpm-config-8.0.34-1

How reproducible:
Always

Steps to Reproduce:
1. specify as compiler gcc32
2. try to rebuild rpm
3.
  

Actual Results:  configure will fail most times as gcc does not produces any valid result

Expected Results:  working rpm rebuild

Additional info:

I am not sure if this option is valid for x86_64 amd anyhow...

Comment 1 Elliot Lee 2005-07-13 18:04:31 UTC
Hi,

Unfortunately, the optflags are only intended to work with the main system
compiler (gcc). Using them with gcc32 is not supported. You may need to
customize any .spec files that use gcc32...


Note You need to log in before you can comment on or make changes to this bug.