Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162859 - initrd fails to umount sysfs.
Summary: initrd fails to umount sysfs.
Keywords:
Status: CLOSED DUPLICATE of bug 163407
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-10 17:18 UTC by Stuart Anderson
Modified: 2015-01-04 22:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-28 19:01:53 UTC


Attachments (Terms of Use)

Description Stuart Anderson 2005-07-10 17:18:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The FC3 update-test kernel, kernel-smp-2.6.12-1.1370_FC3.i686.rpm,
results in the same identical kernel panic at boot time on multiple
dual-P4 Xeon test systems that run 2.6.11-1.35_FC3smp stably,

 >  mount: error 19 mounting ext3
 >  mount: error 2 mounting none
 >  switching to new root
 >  switchroot: mount failed: 22
 >  umount /initrd/dev failed: 2
 >  kernel panic-not synching: attempted to kill init!
 >  [<c0120e85>] panic+0x42/0x1ca
 >  [<c0121ff1>] profile_task_exit+0x31/0x45
 >  [<c0123d8d>] do_exit+0x252/0x35a
 >  [<c0123ebf>] next_thread_0x0/0xc    (could have been [<c0120eb5>])
 >  [<c0103fd9>] syscall_call_0x7/0xb

A manuall rebuild of the initrd file with,
mkinitrd /boot/initrd-2.6.12-1.1370_FC3smp.img 2.6.12-1.1370_FC3smp
did not fix the problem.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.12-1.1370_FC3.i686.rpm

How reproducible:
Always

Steps to Reproduce:
1. Install kernel-smp-2.6.12-1.1370_FC3.i686.rpm on dual-Xeon
2. reboot
3.
  

Additional info:

Comment 1 Dave Jones 2005-07-15 20:36:03 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 2 Stuart Anderson 2005-07-15 21:57:37 UTC
No luck.

I get the exact same panic at boot time with kernel-smp-2.6.12-1.1372_FC3.
If it helps the few lines at boot time before the above are,
creating root device
umount /sys failed: 16
mounting root filesystem

and the correct [<>] value for the next_thread is c0123eb5.

I also tried, 2.6.12-1.1372_FC3, and that boots just fine. I have 420 of
these computers that I would like to upgrade to get some important NFS
fixes so please let me know if there is anything else I can do to help.

Thanks.

Comment 3 Dave Jones 2005-07-15 22:33:11 UTC
Peter, any ideas whats happening there ? 16 is /etc/mtab is unwritable iirc.


Comment 4 Dan Carpenter 2005-07-17 08:51:15 UTC
It's quite likely that this is the same as bug 160652
It's a mkinitrd bug.
A ton of people have been bit by that.


Comment 5 Stuart Anderson 2005-07-17 21:44:39 UTC
Is there a FC3 mkinitrd that has the fix yet?

Comment 6 Stuart Anderson 2005-07-26 17:15:05 UTC
I am really surprised at how long this broken update has been out there.

What is the schedule for fixing this problem and/or pulling the broken
update so it is safe to run "yum update" or equivalent?

I would honestly like to know if this problem had been in FC4 if it
would have gotten more prompt attention? i.e., is this an indication
of a differing level of support between the "supported" versions of FC?

Comment 7 Dave Jones 2005-07-28 19:01:53 UTC

*** This bug has been marked as a duplicate of 163407 ***


Note You need to log in before you can comment on or make changes to this bug.