Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162849 - default build should be feature complete
Summary: default build should be feature complete
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pure-ftpd
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-10 12:22 UTC by Ronny Buchmann
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.0.20-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-01 20:26:51 UTC


Attachments (Terms of Use)
pureftpd.spec conditionals reversed (deleted)
2005-07-10 14:04 UTC, Ronny Buchmann
no flags Details | Diff
spec file patch v2 (deleted)
2005-07-10 14:54 UTC, Ronny Buchmann
no flags Details | Diff

Description Ronny Buchmann 2005-07-10 12:22:26 UTC
Description of problem:
--with ldap     enable ldap support
--with mysql    enable mysql support
--with pgsql    enable postgresql support
--with extauth  enable external authentication

should be all enabled by default, otherwise updates from Extras will break the
installation

changing the build options to --without ...

Comment 1 Ronny Buchmann 2005-07-10 14:02:37 UTC
same goes for TLS/SSL

Comment 2 Ronny Buchmann 2005-07-10 14:04:03 UTC
Created attachment 116568 [details]
pureftpd.spec  conditionals reversed

Comment 3 Ronny Buchmann 2005-07-10 14:54:14 UTC
Created attachment 116570 [details]
spec file patch v2

use /etc/pki/pure-ftpd for ssl cert storage

Comment 4 Aurelien Bompard 2005-08-01 20:26:13 UTC
That makes sense, I've applied the patch. Rebuild underway.

Comment 5 Jose Pedro Oliveira 2005-08-04 03:57:27 UTC
Sniff!

Do we really need to build pure-ftpd feature complete?  In my case (mostly
anonymous public servers) it would mean to install the mysql and postgres
libraries (among other possible deps).

Yum output:
...
Updating:
 pure-ftpd               i386       1.0.20-3.fc4     extras            226 k
Installing for dependencies:
 mysql                   i386       4.1.12-2.FC4.1   updates-released  2.8 M
 perl-DBI                i386       1.48-4           base              571 k
 postgresql-libs         i386       8.0.3-1          base              180 k
...


Would it be possible to do something like in vim and create the following
packages (package names not mandatory):
  * pure-ftpd-common
  * pure-ftpd-minimal   (minimal features as in pure-ftpd-1.0.20-2.fc3)
  * pure-ftpd-enhanced  (or full) (build feature complete)

Note: it will be tricky to be have both daemons installed (minimal and
enhanced/full).

Any thoughts,
jpo


Comment 6 Aurelien Bompard 2005-08-04 07:55:04 UTC
Well, the problem is that the package can't be split, it's really compilation
options. There can't be a pure-ftpd-common, it's not plugin-based.
At least it only means installing the libs, not the servers...

I'll ask upstream for a plugin system, but it looks to me like pure-ftpd was
designed for FreeBSD.

If someone has another option...

Comment 7 Ronny Buchmann 2005-08-04 17:35:33 UTC
Principally the package could be split, but that would mean conflicting packages
(or an even bigger mess), I'm not sure if this would be acceptable for extras.

pure-ftpd-common:
 utilities, docs

pure-ftpd-minimal:
 daemon (minimal compile options)
 config

pure-ftpd-full:
 daemon (feature complete)
 config

pure-ftpd-ldap
...

to comment5:
Jose, why don't you use vsftpd?

Comment 8 Jose Pedro Oliveira 2005-08-04 19:52:59 UTC
Reply to  question of comment #7

Because I have been using it since since version 0.9x (0.97 or 0.99: don't
remember which) and it fulfilled all my needs (and was much easier to setup than
wu_ftpd or proftpd). Also IIRC vsftpd only appeared several years later.




Note You need to log in before you can comment on or make changes to this bug.