Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162848 - kernel locks up after accessing a blank cdrw (after it was just blanked)
Summary: kernel locks up after accessing a blank cdrw (after it was just blanked)
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-10 11:23 UTC by Pascal de Bruijn
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-18 12:28:57 UTC


Attachments (Terms of Use)

Description Pascal de Bruijn 2005-07-10 11:23:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
My system hangs when I have just blanked a CDRW and I try to access it afterwards, through nautilus.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1390_FC4

How reproducible:
Always

Steps to Reproduce:
1. Put an already burnt CDRW into the CD Recorder's drive
2. cdrecord dev=/dev/hdc speed=10  blank=fast
3. (do not eject the cdrw)
4. (the empty cdrw doesn't show up on my desktop)
5. Then I go to Places - Computer - CDROM Drive


Actual Results:  The system hangs totally. I can't even use Ctrl-Alt-F1 to get to my text console.

Expected Results:  Nautilus should have presented me the CD Burning dialog.

Additional info:

I couldn't find much suspicious in my /var/log/messages file, except for this:

Jul 10 12:55:09 agamemnon kernel: scsi: unknown opcode 0x01

Comment 1 Andre Robatino 2005-07-10 15:53:24 UTC
  This is probably a dupe of bug #162347.

Comment 2 Pascal de Bruijn 2005-07-10 18:44:56 UTC
Hmmm, I looked at that one, could be the same issue, except that I can't seem to
be able to reproduce the same dmesg as he does...

Also I never have issues while booting. And I only have that issue after trying
to access a just refreshly blanked cdrw. If I blank the cdrw and reboot, and
access it after the reboot, I'm totally fine!

Regards,
Pascal de Bruijn

Comment 3 Dave Jones 2005-07-15 21:08:44 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 4 Pascal de Bruijn 2005-07-18 12:28:57 UTC
I've just upgraded to the lastest kernel: 
* 2.6.12-1.1398_FC4

And I can't seem to be able to reprocedure the issue anymore.

Thanks for the help!
Pascal de Bruijn

I 


Note You need to log in before you can comment on or make changes to this bug.