Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162847 - 64bit libopenobex.so is missing
Summary: 64bit libopenobex.so is missing
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openobex
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-10 11:16 UTC by Markus Hakansson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-14 08:38:30 UTC


Attachments (Terms of Use)

Description Markus Hakansson 2005-07-10 11:16:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; sv-SE; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
The x86_64 version of openobex-devel only contains the /usr/lib64/libopenobex.a and a broken symlink named /usr/lib64/libopenobex.so

Version-Release number of selected component (if applicable):
openobex-devel-1.0.1-3

How reproducible:
Always

Steps to Reproduce:
1. Install openobex-devel RPM
2. ls -la /usr/lib64/libopenobex.so

Additional info:

Comment 1 Harald Hoyer 2005-07-11 11:02:01 UTC
$ rpm -qpl  openobex-1.0.1-3.x86_64.rpm
/usr/lib64/libopenobex-1.0.so.1
/usr/lib64/libopenobex-1.0.so.1.0.0

$ rpm -qvpl openobex-devel-1.0.1-3.x86_64.rpm
...
/usr/lib64/libopenobex.so -> libopenobex-1.0.so.1.0.0
...

seems to be ok ... 

Comment 2 Markus Hakansson 2005-07-13 20:35:42 UTC
Perhaps I am missing something here, but the output you get shows my point
exactly. There is a symlink in the RPM but the library is missing, isn't it?
Or is that the way it should be?

# rpm -qvl openobex-devel-1.0.1-3.x86_64 | grep libopenobex.so
lrwxrwxrwx 1 root root 24 mar  2 15:19 /usr/lib64/libopenobex.so ->
libopenobex-1.0.so.1.0.0
# ll /usr/lib64/libopenobex.so
lrwxrwxrwx  1 root root 24 10 jul 13.09 /usr/lib64/libopenobex.so ->
libopenobex-1.0.so.1.0.0
# ll /usr/lib64/libopenobex-1.0.so.1.0.0
ls: /usr/lib64/libopenobex-1.0.so.1.0.0: No such file or directory


Comment 3 Harald Hoyer 2005-07-14 08:38:30 UTC
the .so symlink from openobex-devel-1.0.1-3.x86_64.rpm points to the real file
from openobex-1.0.1-3.x86_64.rpm. install openobex-1.0.1-3.x86_64.rpm and you
are fine.


Note You need to log in before you can comment on or make changes to this bug.