Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162846 - yum checks wrong package for $releasever
Summary: yum checks wrong package for $releasever
Keywords:
Status: CLOSED DUPLICATE of bug 161071
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date
Version: 4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-10 11:08 UTC by Henning Schmiedehausen
Modified: 2014-01-21 22:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-12 06:39:47 UTC


Attachments (Terms of Use)
Our internal definition for the "Fedora Extras" Repository (deleted)
2005-07-10 15:39 UTC, Henning Schmiedehausen
no flags Details

Description Henning Schmiedehausen 2005-07-10 11:08:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
On fedora, yum should check fedora-release to set the value of the $releasever
variable. This does work on FC3. However, on FC4, there is "redhat-relase" as distroverpkg instead of "fedora-release"

Version-Release number of selected component (if applicable):
yum-2.3.2-7

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 4 (do not upgrade!)
2. less /etc/yum.conf
3. search for distroverpkg
  

Actual Results:  Is "redhat-release"

Expected Results:  Should be "fedora-release"

Additional info:

I set the level of this bug to "high" because it prevents updates from yum repositories.

Yum seems to fall back to some internal default and uses "3" as the version and tries subsequently to update from a Core/3 repository...

Comment 1 Seth Vidal 2005-07-10 14:05:41 UTC

*** This bug has been marked as a duplicate of 123888 ***

Comment 2 Henning Schmiedehausen 2005-07-10 15:38:44 UTC
I admit, I was wrong and I opened it for the wrong component. It seems to be an
up2date bug. I attached the "intermeta-fedora-extras.repo" to this bug report.
There definitely is something fishy in up2date which lets it fall back to "3" as
releasever. If I replace the "$releasever" reference in the repo file with a
hard coded "4", then everything works fine.


# up2date -i yap

initRepo
Baseurl(s) for repo: ['http://yum.intermeta.de/yum/Fedora/Core/4/extras/i386/']
Setting up Package Sacks
Excluding Incompatible Archs
Finished
Setting up Package Sacks
Excluding Incompatible Archs
Finished

Fetching Obsoletes list for channel: intermeta-extras...
initRepo

Fetching obsoletes list for
http://yum.intermeta.de/yum/Fedora/Core/3/extras/i386/...

Fetching rpm headers...
initRepo
bytes=440-32978
There was a fatal error communicating with the server. The message was:

An HTTP error occurred:
URL: http://yum.intermeta.de/yum/Fedora/Core/3/extras/i386//yap-4.5.5-6.fc4.i386.rpm
Status Code: 404
Error Message: Not Found

Same configuration with yum:

# yum install yap
Setting up repositories
intermeta-extras          100% |=========================|  951 B    00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for yap to pack into transaction set.
yap-4.5.5-6.fc4.i386.rpm  100% |=========================|  32 kB    00:00
---> Package yap.i386 0:4.5.5-6.fc4 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 yap                     i386       4.5.5-6.fc4      intermeta-extras  2.3 M

Transaction Summary
=============================================================================
Install      1 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 2.3 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): yap-4.5.5-6.fc4.i3 100% |=========================| 2.3 MB    00:01
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: yap                          ######################### [1/1]

Installed: yap.i386 0:4.5.5-6.fc4
Complete!



Comment 3 Henning Schmiedehausen 2005-07-10 15:39:54 UTC
Created attachment 116571 [details]
Our internal definition for the "Fedora Extras" Repository

Comment 4 Paul Howarth 2005-07-11 16:24:24 UTC
Looks to me like a duplicate of Bug #161071


Comment 5 Henning Schmiedehausen 2005-07-12 06:39:47 UTC
yep, that is right.

*** This bug has been marked as a duplicate of 161071 ***


Note You need to log in before you can comment on or make changes to this bug.