Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162844 - vipw and vigw are unusable, and complain about terminal input/output error
Summary: vipw and vigw are unusable, and complain about terminal input/output error
Keywords:
Status: CLOSED DUPLICATE of bug 163303
Alias: None
Product: Fedora
Classification: Fedora
Component: utempter
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-10 10:09 UTC by Gravis
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-28 15:26:37 UTC


Attachments (Terms of Use)

Description Gravis 2005-07-10 10:09:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:


I can't edit my password or group files using vigw and vipw.

Version-Release number of selected component (if applicable):
2.12p-9.5

How reproducible:
Always

Steps to Reproduce:
1. run vipw or vigw
2.
3.
  

Actual Results:  Vim: Warning: Output is not to a terminal
Vim: Warning: Input is not from a terminal

and all vim commands don't work :

/mysearch prints "/mysearch" and override text in file !
lucky :q works :)

Expected Results:  editing file with vim

Additional info:

also broken on a fresh install

Comment 1 Charles C. Van Tilburg 2005-07-28 13:38:42 UTC
selinux may have something to do with this as well... from messages:

Jul 28 08:13:41 beast kernel: audit(1122552821.987:3): avc:  denied  { search }
for  pid=2512 comm="vipw" name="/" dev=hda3 ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=system_u:object_r:home_root_t
tclass=dir
Jul 28 08:13:41 beast kernel: audit(1122552821.988:4): avc:  denied  { search }
for  pid=2512 comm="vipw" name="/" dev=hda3 ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=system_u:object_r:home_root_t
tclass=dir
Jul 28 08:13:41 beast kernel: audit(1122552821.988:5): avc:  denied  { search }
for  pid=2512 comm="vipw" name="/" dev=hda3 ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=system_u:object_r:home_root_t
tclass=dir
Jul 28 08:13:42 beast kernel: audit(1122552822.190:6): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:42 beast kernel: audit(1122552822.192:7): avc:  denied  { search }
for  pid=2512 comm="vi" name="/" dev=hda3 ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=system_u:object_r:home_root_t
tclass=dir
Jul 28 08:13:42 beast kernel: audit(1122552822.193:8): avc:  denied  { search }
for  pid=2512 comm="vi" name="/" dev=hda3 ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=system_u:object_r:home_root_t
tclass=dir
Jul 28 08:13:42 beast kernel: audit(1122552822.193:9): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:44 beast kernel: audit(1122552824.196:10): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:44 beast kernel: audit(1122552824.196:11): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:44 beast kernel: audit(1122552824.197:12): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:44 beast kernel: audit(1122552824.197:13): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:44 beast kernel: audit(1122552824.197:14): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:44 beast kernel: audit(1122552824.198:15): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:44 beast kernel: audit(1122552824.199:16): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:44 beast kernel: audit(1122552824.199:17): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:44 beast kernel: audit(1122552824.199:18): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:44 beast kernel: audit(1122552824.200:19): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:44 beast kernel: audit(1122552824.201:20): avc:  denied  { search }
for  pid=2512 comm="vi" name="/" dev=hda3 ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=system_u:object_r:home_root_t
tclass=dir
Jul 28 08:13:44 beast kernel: audit(1122552824.217:21): avc:  denied  { search }
for  pid=2512 comm="vi" name="/" dev=hda3 ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=system_u:object_r:home_root_t
tclass=dir
Jul 28 08:13:44 beast kernel: audit(1122552824.217:22): avc:  denied  { search }
for  pid=2512 comm="vi" name="/" dev=hda3 ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=system_u:object_r:home_root_t
tclass=dir
Jul 28 08:13:44 beast kernel: audit(1122552824.218:23): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:44 beast kernel: audit(1122552824.218:24): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file
Jul 28 08:13:45 beast kernel: audit(1122552825.240:25): avc:  denied  { ioctl }
for  pid=2512 comm="vi" name="0" dev=devpts ino=2
scontext=root:system_r:sysadm_passwd_t tcontext=root:object_r:devpts_t
tclass=chr_file


Comment 2 Charles C. Van Tilburg 2005-07-28 13:46:42 UTC
setenforce 0 causes vipw to work just fine...

Comment 3 Charles C. Van Tilburg 2005-07-28 14:59:06 UTC
bug 163303 deals with this as well...

Comment 4 Karel Zak 2005-07-28 15:26:37 UTC

*** This bug has been marked as a duplicate of 163303 ***


Note You need to log in before you can comment on or make changes to this bug.