Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162839 - deprecated GTK warning for system-config-date
Summary: deprecated GTK warning for system-config-date
Keywords:
Status: CLOSED DUPLICATE of bug 162840
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-date
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-10 06:23 UTC by Arenas Belon, Carlo Marcelo
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-10 06:29:08 UTC


Attachments (Terms of Use)

Description Arenas Belon, Carlo Marcelo 2005-07-10 06:23:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
when executing system-config-date the following is returned on the controling terminal :

/usr/share/system-config-date/mainWindow.py:155: GtkDeprecationWarning: gtk.timeout_add is deprecated, use gobject.timeout_add instead
  id = gtk.timeout_add(20, lambda:1)
/usr/share/system-config-date/mainWindow.py:161: GtkDeprecationWarning: gtk.idle_remove is deprecated, use gobject.source_remove instead
  gtk.idle_remove (id)

and which is being used on the following snippet :

  #work around http://bugzilla.gnome.org/show_bug.cgi?id=72333 )-;
  id = gtk.timeout_add(20, lambda:1)
  if gtk.__dict__.has_key ("main"):
      gtk.main ()
  else:
      gtk.mainloop()
  dlg.destroy()
  gtk.idle_remove (id)



Version-Release number of selected component (if applicable):
1.7.18-1

How reproducible:
Always

Steps to Reproduce:
1. open terminal
2. system-config-date
3.
  

Actual Results:  GTK deprecation warnings

Expected Results:  clean execution

Additional info:

Comment 1 Arenas Belon, Carlo Marcelo 2005-07-10 06:29:08 UTC

*** This bug has been marked as a duplicate of 162840 ***


Note You need to log in before you can comment on or make changes to this bug.