Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162817 - Can't upgrade from FC2 : partition table not found on device
Summary: Can't upgrade from FC2 : partition table not found on device
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-08 22:08 UTC by Emmanuel Druon
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-30 18:35:36 UTC


Attachments (Terms of Use)

Description Emmanuel Druon 2005-07-08 22:08:44 UTC
Description of problem:
When trying to upgrade (or install) an FC4 over a workable FC2 install (on a
dual boot system), the partition table is not read correctly with anaconda. The
installation stops with a "partition table on device hda was unreadable..."
message. If a switch to text console 2, I can do an fdisk on the disk hda
without any problem (or error message) and /tmp/syslog doesn't indicate any
error reading the partition table on hda. Having to many data on the disk
(Seagate ST380022A Ata Drive), I can't afford deleting the existing partition to
try everything from scratch.


Version-Release number of selected component (if applicable):


How reproducible:
Each time

Steps to Reproduce:
1. boot from the FC4 DVD
2. the installer don't find any previous install and displays an error message
3.
  
Actual results:
Can't upgrade or install FC4

Expected results:


Additional info:

Comment 1 Jeremy Katz 2005-07-12 15:12:02 UTC
Can parted see the partition table?

Comment 2 Emmanuel Druon 2005-08-26 09:20:03 UTC
Sorry for the delay but I've been out for quite some time. Unfortunately, I
can't send any more information about this bug since to solve my problem, I've
backed up my data, deleted my "rebelous" partitions and recreated them. Doing so
solved my installation problem...
Might close this bug unless someone around has the same problem.

Emmanuel


Note You need to log in before you can comment on or make changes to this bug.