Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162802 - gcj complains regular expressions
Summary: gcj complains regular expressions
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 4
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom Tromey
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-08 18:50 UTC by Ivan Sedo
Modified: 2014-08-11 05:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-13 23:26:39 UTC


Attachments (Terms of Use)

Description Ivan Sedo 2005-07-08 18:50:05 UTC
Description of problem:
I'd like to use tools from 
http://multivalent.sourceforge.net/
but if I try to execute (I only tried it on) Validate, I get this error

Exception in thread "main"
java.lang.ExceptionInInitializerError
   at java.lang.Class.initializeClass()
(/usr/lib/libgcj.so.6.0.0)
   at tool.pdf.Validate.main(java.lang.String[])
(Unknown Source)
   at gnu.java.lang.MainThread.call_main()
(/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run()
(/usr/lib/libgcj.so.6.0.0)
Caused by: java.util.regex.PatternSyntaxException: At
position 1 in regular expression pattern:
quantifier (?*+{}) without preceding token
        (?i)\.pdf$
         ^
   at java.util.regex.Pattern.Pattern(java.lang.String,
int) (/usr/lib/libgcj.so.6.0.0)
   at java.util.regex.Pattern.compile(java.lang.String,
int) (/usr/lib/libgcj.so.6.0.0)
   at java.util.regex.Pattern.compile(java.lang.String)
(/usr/lib/libgcj.so.6.0.0)
   at
phelps.io.FileFilterPattern.FileFilterPattern(java.lang.String)
(Unknown Source)
   at multivalent.std.adaptor.pdf.COS.<clinit>()
(Unknown Source)
   at java.lang.Class.initializeClass()
(/usr/lib/libgcj.so.6.0.0)
   ...3 more
Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. try to use it on some file
2.
3.
  
Actual results:
exception raised

Expected results:
should work without exceptions

Additional info:
I contacted the developer of multivalent tool firstly and he wrote, it could be
a gcj issue

Comment 1 Thomas Fitzsimmons 2005-10-01 21:42:52 UTC
This should probably be filed at gcc.gnu.org/bugzilla.  It'd be great to have a
minimal test case for this.  Reassigning to Tom Tromey.


Comment 2 Tom Tromey 2006-01-23 22:00:55 UTC
Test case:

import java.util.regex.*;
public class t {
  public static void main(String[] args) {
    System.out.println(Pattern.compile("(?i)\\.pdf$"));
  }
}


Comment 3 Tom Tromey 2006-01-26 00:45:42 UTC
Ito's regex fixes in Classpath fix this bug.
I'm investigating whether to pull these into gcc4.1 / fc5


Comment 4 Tom Tromey 2006-02-13 23:26:39 UTC
I put the patches in 4.1.
They are either in rawhide now, or will be shortly.
So, I'm closing this.



Note You need to log in before you can comment on or make changes to this bug.