Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162784 - /media mount points not in same order as /dev devices
Summary: /media mount points not in same order as /dev devices
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-08 16:47 UTC by John Reiser
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-08 17:21:23 UTC


Attachments (Terms of Use)

Description John Reiser 2005-07-08 16:47:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
If there are two CD drives on one (E)IDE channel, then the mount name in /media does not correspond to the /dev name.  For instance, I have a DVD-R on hdc and a CD-R on hdd.  These appear in /dev as
-----
$ ls -l /dev/cd*
lrwxrwxrwx  1 root root    3 Jul  8 06:42 /dev/cdrom -> hdc
lrwxrwxrwx  1 root root    3 Jul  8 06:42 /dev/cdrom1 -> hdd
lrwxrwxrwx  1 root root    3 Jul  8 06:42 /dev/cdwriter -> hdc
lrwxrwxrwx  1 root root    3 Jul  8 06:42 /dev/cdwriter1 -> hdd
-----
but when I insert a DVD into hdc, it gets automounted as:
$ mount | grep hdc
/dev/hdc on /media/cdrecorder1 type iso9660 (ro,nosuid,nodev,_netdev,user=jreiser)
-----

This creates confusion.  The names should be in the same order, and it should be hdc first, then hdd.  In the case above, the DVD should have been mounted on /media/cdrecorder (no trailing '1').




Version-Release number of selected component (if applicable):
gnome-desktop-2.10.0-5

How reproducible:
Always

Steps to Reproduce:
1. Build a box with two CD devices on the same IDE channel.
2. Insert a disc on the IDE master device.
3. Check where it gets mounted.


  

Actual Results:  The disk in the master device is mounted as /media/cdrecorder1, instead of as /media/cdrecorder.


Expected Results:  The name for anything connected to the master device should come first, with no trailing '1' in its /media mount point.


Additional info:

Comment 1 David Zeuthen 2005-07-08 17:21:23 UTC
Not a bug actually. Note that all this is subject to change for FC5 where we'll
be switching to a policy based mount wrapper, e.g. no /etc/fstab entries at all.


Note You need to log in before you can comment on or make changes to this bug.