Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162783 - Bogus flock(1) in util-linux package breaks kernel.org
Summary: Bogus flock(1) in util-linux package breaks kernel.org
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-08 16:39 UTC by H. Peter Anvin
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-05 14:01:49 UTC


Attachments (Terms of Use)

Description H. Peter Anvin 2005-07-08 16:39:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
Since FC4 at least, the util-linux package has added an flock(1) utility from Adam Richter.  Unfortunately this is incompatible with and much more limited than a preexisting flock(1) utility used on kernel.org.

http://www.kernel.org/pub/software/utils/script/flock/

THIS HAS ALREADY BROKEN KERNEL.ORG ONCE AND IS THREATENING TO DO SO AGAIN.

Please unbundle this utility from the critical util-linux package, and preferrably, please include the kernel.org utility in your distribution.


Version-Release number of selected component (if applicable):
util-linux-2.12p-9.3

How reproducible:
Always

Steps to Reproduce:
Execute "flock -x 2"

  

Actual Results:  Error message

Expected Results:  Exclusive lock on file descriptor 2


Additional info:

Comment 1 H. Peter Anvin 2005-07-08 16:40:32 UTC
I have tried to contact the util-linux maintainers about this issue as well.


Comment 2 H. Peter Anvin 2005-07-11 05:44:26 UTC
At the request of the util-linux maintainers, I have updated my version of flock
to become a proper superset of the one currently in util-linux.

See the URL above.


Comment 3 Karel Zak 2005-07-12 10:21:57 UTC
I don't want to change any util in FC4 update. We can think about it for FC5.
You're right that your flock version looks better. It would be nice if you add
locale support to your code:

    setlocale(LC_ALL, "");
    bindtextdomain(PACKAGE, LOCALEDIR);
    textdomain(PACKAGE);


Comment 4 Karel Zak 2005-09-05 14:01:49 UTC
Accepted by upstream, already in FC5.


Note You need to log in before you can comment on or make changes to this bug.