Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162782 - Internal Compiler Error compiling objective-C model
Summary: Internal Compiler Error compiling objective-C model
Keywords:
Status: CLOSED DUPLICATE of bug 161529
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-08 16:37 UTC by Paul Johnson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-08 18:18:48 UTC


Attachments (Terms of Use)
info gcc creates on internal compiler error (deleted)
2005-07-08 17:49 UTC, Paul Johnson
no flags Details

Description Paul Johnson 2005-07-08 16:37:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Warnings in Objective-C cause gcc to crash.  Same problem DOES NOT occur with gcc 4 on a Macintosh (using the newest gcc from Apple)

if /bin/sh ./libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I/home/pauljohn/LinuxDownloads/                       
redhat/BUILD/swarm-2.2/libobjc -I. -I./objc -I/home/pauljohn/LinuxDownloads/redhat/BUILD/swa                       
rm-2.2/libobjc/objc -I/home/pauljohn/LinuxDownloads/redhat/BUILD/swarm-2.2/libobjc   -DBUILD                       
ING_LIBOBJC  -g -O2 -g -march=i386 -mcpu=i686 -fgnu-runtime -fno-strict-aliasing -Wall -Wno-                       
import -Wno-protocol -Wno-long-long -fgnu-runtime -fno-strict-aliasing -Wall -Wno-import -Wn                       
o-protocol -Wno-long-long -MT mframe.lo -MD -MP -MF ".deps/mframe.Tpo" -c -o mframe.lo /home                       
/pauljohn/LinuxDownloads/redhat/BUILD/swarm-2.2/libobjc/mframe.m; \
then mv -f ".deps/mframe.Tpo" ".deps/mframe.Plo"; else rm -f ".deps/mframe.Tpo"; exit 1; fi
 gcc -DHAVE_CONFIG_H -I. -I/home/pauljohn/LinuxDownloads/redhat/BUILD/swarm-2.2/libobjc -I.                        
-I./objc -I/home/pauljohn/LinuxDownloads/redhat/BUILD/swarm-2.2/libobjc/objc -I/home/pauljoh                       
n/LinuxDownloads/redhat/BUILD/swarm-2.2/libobjc -DBUILDING_LIBOBJC -g -O2 -g -march=i386 -mc                       
pu=i686 -fgnu-runtime -fno-strict-aliasing -Wall -Wno-import -Wno-protocol -Wno-long-long -f                       
gnu-runtime -fno-strict-aliasing -Wall -Wno-import -Wno-protocol -Wno-long-long -MT mframe.l                       
o -MD -MP -MF .deps/mframe.Tpo -c /home/pauljohn/LinuxDownloads/redhat/BUILD/swarm-2.2/libob                       
jc/mframe.m  -DPIC
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
/home/pauljohn/LinuxDownloads/redhat/BUILD/swarm-2.2/libobjc/mframe.m: In function 'mframe_d                       
ecode_return':
/home/pauljohn/LinuxDownloads/redhat/BUILD/swarm-2.2/libobjc/mframe.m:1728: internal compile                       
r error: in assign_stack_temp_for_type, at function.c:605
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cckUR8m2.out file, please attach this to your bugreport                       
.
make[4]: *** [mframe.lo] Error 1
make[4]: Leaving directory `/home/pauljohn/LinuxDownloads/redhat/BUILD/swarm-2.2/=with-hdf/l                       
ibobjc'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/pauljohn/LinuxDownloads/redhat/BUILD/swarm-2.2/=with-hdf/l                       
ibobjc'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/pauljohn/LinuxDownloads/redhat/BUILD/swarm-2.2/=with-hdf/l                       
ibobjc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/pauljohn/LinuxDownloads/redhat/BUILD/swarm-2.2/=with-hdf'
make: *** [all] Error 2


Version-Release number of selected component (if applicable):
gcc-4.0.0-8

How reproducible:
Always

Steps to Reproduce:
1. Get Swarm simulation libraries (http://www.swarm.org
2. configure, then try to compile
3.
  

Actual Results:  ICE

Additional info:

Comment 1 Paul Johnson 2005-07-08 17:49:07 UTC
Created attachment 116526 [details]
info gcc creates on internal compiler error

Here's the file the ICE says I should send to you

Comment 2 Paul Johnson 2005-07-08 18:18:48 UTC
I did not use the correct key words when I searched before, but now I found the
same thing is a known bug.

*** This bug has been marked as a duplicate of 161529 ***


Note You need to log in before you can comment on or make changes to this bug.