Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162763 - i586 kernel modules show wrong arch in vermagic
Summary: i586 kernel modules show wrong arch in vermagic
Keywords:
Status: CLOSED DUPLICATE of bug 165603
Alias: None
Product: Fedora
Classification: Fedora
Component: cman-kernel
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-08 13:36 UTC by Chris Evich
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-29 21:03:47 UTC


Attachments (Terms of Use)

Description Chris Evich 2005-07-08 13:36:43 UTC
Description of problem:
Have a somewhat FC4 box that I'm trying to setup as a gnbd server.  All the
cluster stuff installed fine and without error (after manually finding and
resolving upgrade dependencies).  When trying to load any of the cluster modules
I get a "Invalid module format" error.  Looking in messages it indicates the
vermagic is wrong for the module.  Further investigation shows:

# QF='%{name}-%{version}-%{release}.%{arch}\n'
# rpm -q --qf "$QF" cman-kernel
cman-kernel-2.6.11.5-20050601.152643.FC4.2.i586
# modinfo -F vermagic cman
2.6.11-1.1369_FC4 686 REGPARM 4KSTACKS gcc-4.0
# rpm -q --qf "$QF" dlm-kernel
dlm-kernel-2.6.11.5-20050601.152643.FC4.2.i586
# modinfo -F vermagic dlm
2.6.11-1.1369_FC4 686 REGPARM 4KSTACKS gcc-4.0
# rpm -q --qf "$QF" gnbd-kernel
gnbd-kernel-2.6.11.2-20050420.133124.FC4.35.i586
# modinfo -F vermagic gnbd
2.6.11-1.1369_FC4 686 REGPARM 4KSTACKS gcc-4.0
# uname -vrpimo
2.6.11-1.1369_FC4 #1 Thu Jun 2 22:53:35 EDT 2005 i586 i586 i386 GNU/Linux
# rpm -q --qf "$QF" gcc
gcc-4.0.0-0.40.i386
# rpm -q --qf "$QF" glibc glibc-kernheaders
glibc-2.3.5-0.fc3.1.i386
glibc-kernheaders-2.4-9.1.87.i386
#

As you can see, the i586 packages are installed but the actual modules are
tagged i686, perhaps there was a mistake building from the SRPM?

Comment 1 Chris Evich 2005-07-19 11:52:21 UTC
Found the same to be true for the GFS modules as well.  Also checked the later
2.6.12-1398 kernel, it has the same problem.

Comment 2 Chris Feist 2005-07-19 19:44:23 UTC
The problem is caused by looking for kernel devel information in
/lib/modules/`uname -r`/build we need to be looking for that information in
/usr/src/kernels/`unamr -r`-i586.  I'll work on getting this fixed.

Comment 3 Chris Feist 2006-09-29 21:03:47 UTC

*** This bug has been marked as a duplicate of 165603 ***


Note You need to log in before you can comment on or make changes to this bug.