Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162752 - lockups with Athlon64 X2 and warm reboot
Summary: lockups with Athlon64 X2 and warm reboot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-08 12:30 UTC by Noa Resare
Modified: 2015-01-04 22:20 UTC (History)
2 users (show)

Fixed In Version: 2.6.12-1.1447_FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-05 09:03:45 UTC


Attachments (Terms of Use)
dmesg (deleted)
2005-07-19 07:33 UTC, Noa Resare
no flags Details
lsmod (deleted)
2005-07-19 07:35 UTC, Noa Resare
no flags Details
lspci (deleted)
2005-07-19 07:36 UTC, Noa Resare
no flags Details

Description Noa Resare 2005-07-08 12:30:07 UTC
Description of problem:

I experience hard lockups of my system with kernel-smp-2.6.12-1.1390_FC4 after
 a few minutes <10. kernel-smp-2.6.12-1.1387_FC4 has been running for a few
days without problems.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.12-1.1390_FC4

How reproducible:
i've done it twice, both times after about 5 minutes.

Steps to Reproduce:
1. boot my system with kernel-smp-2.6.12-1.1390_FC4 from fc4 updates
2. login, check some email for a few minutes
3.
  
Actual results:
hard lockup of the system. No mouse movement, doesn't answer to ping.

Expected results:
stable

Additional info:

Motherboard: nForce4-based (Asus A8N-E, )
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Memory: 2GB Samsung (KVR400X64C3AK2/2G)

plenty of cooling, after having tried to get some reponse from the machine i
jumped into SETUP after reboot, and the reported processor temp was about 35C

Comment 1 Dave Jones 2005-07-08 23:03:31 UTC
can you try running memtest on this box for a while ?

also the output of dmesg, lsmod and lspci would be useful.


Comment 2 Dave Jones 2005-07-15 21:10:26 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 3 Noa Resare 2005-07-19 07:32:11 UTC
sorry for the delay, I think now that I've found a pattern.

It doen't matter which one of the FC4 kernels I run, what does matter however is
if i reboot the machine cold or warm. Cold reboot gives a stable system. Warm
reboot locks up after a few minutes.

Comment 4 Noa Resare 2005-07-19 07:33:57 UTC
Created attachment 116912 [details]
dmesg

Comment 5 Noa Resare 2005-07-19 07:35:14 UTC
Created attachment 116913 [details]
lsmod

Comment 6 Noa Resare 2005-07-19 07:36:01 UTC
Created attachment 116914 [details]
lspci

Comment 7 Dave Jones 2005-08-26 08:40:39 UTC
try service stop cpuspeed, and see if stability improves.
If so, it's likely a bug that's fixed in the current kernel in updates-testing


Comment 8 Noa Resare 2005-08-31 14:51:26 UTC
Just back from a vacation i just tried to reproduce the lockup with
2.6.12-1.1447_FC4smp but it seems to have been fixed. Thanks! Closing this
tomorrow after a night of stress tests.


Note You need to log in before you can comment on or make changes to this bug.