Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162748 - bootstrap-ecj fails on s390x
Summary: bootstrap-ecj fails on s390x
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat
Version: rawhide
Hardware: s390x
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gary Benson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-08 09:26 UTC by Gary Benson
Modified: 2008-04-02 22:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-02 22:27:25 UTC


Attachments (Terms of Use)

Description Gary Benson 2005-07-08 09:26:25 UTC
javac fails on s390x:

[root@spud ~]# javac
Exception in thread "main" java.lang.ExceptionInInitializerError
   at java.lang.Class.initializeClass() (/usr/lib64/libgcj.so.6.0.0)
   at org.eclipse.jdt.internal.compiler.batch.Main.main(java.lang.String[])
(/usr/lib64/gcj/java-1.4.2-gcj-compat/eclipse-ecj.jar.so)
   at .JvRunMain (/usr/lib64/libgcj.so.6.0.0)
   at .__libc_start_main (/lib64/libc-2.3.5.so)
Caused by: java.lang.NullPointerException
   at org.eclipse.jdt.internal.compiler.batch.Main.relocalize()
(/usr/lib64/gcj/java-1.4.2-gcj-compat/eclipse-ecj.jar.so)
   at org.eclipse.jdt.internal.compiler.batch.Main.<clinit>()
(/usr/lib64/gcj/java-1.4.2-gcj-compat/eclipse-ecj.jar.so)
   at java.lang.Class.initializeClass() (/usr/lib64/libgcj.so.6.0.0)
   ...3 more

Note that the s390x buildroots are  /mnt/build/beehive/dist-fc5-build:1

Comment 1 Gary Benson 2005-07-08 12:42:40 UTC
This does not happen if you replace the binary /usr/bin/ecj with a script.

Comment 2 Thomas Fitzsimmons 2008-04-02 22:27:25 UTC
javac should work on s390x in OpenJDK.  Closing this old bug.


Note You need to log in before you can comment on or make changes to this bug.