Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162733 - Resolution of external video from laptop fixed at 800x600
Summary: Resolution of external video from laptop fixed at 800x600
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
: 163312 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-08 04:58 UTC by Graham freeman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-14 08:56:21 UTC


Attachments (Terms of Use)
xorg.conf (deleted)
2005-07-08 05:36 UTC, Graham freeman
no flags Details
Log file from X start-up (deleted)
2005-07-08 05:37 UTC, Graham freeman
no flags Details

Description Graham freeman 2005-07-08 04:58:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

Description of problem:
I need to use my laptop with external data projection facilities.  Under an old RedHat system with XFree86, I had no trouble, even if the screen resolution was 1600x1200.  With FC2 and FC4, the resolution I am using on the local screen is 1280x1024.  Only an 800x600 piece of the area gets projected through the video connection.

I have tried this in 3 venues.  With a small portable data projector, I have no problem; the full 1280x1024 is projected.  In the other venues (large halls with fixed facilities), I only get the 800x600 displayed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Connect and turn on the data projector.
2. Boot the computer
3.
  

Actual Results:  800x600 portion of the screen display is projected.  If I move the mouse, the displayed area always tracks the cursor.

Expected Results:  The projected screen should match the screen on the local laptop.

Additional info:

The laptop I am using is an IBM ThinkPad.

Comment 1 Graham freeman 2005-07-08 05:36:35 UTC
Created attachment 116505 [details]
xorg.conf

Comment 2 Graham freeman 2005-07-08 05:37:43 UTC
Created attachment 116506 [details]
Log file from X start-up

Comment 3 Walter Justen 2005-08-26 10:07:56 UTC
*** Bug 163312 has been marked as a duplicate of this bug. ***

Comment 4 Mike A. Harris 2005-08-30 10:08:01 UTC
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL for
tracking.

Comment 5 Graham freeman 2005-09-01 06:34:19 UTC
I am sorry for the duplicate bug report (163312).  I did not keep a record of
the bug number.
In that report, I indicated that I found a solution to the problem, by
hand-editing the X configuration file:

Section "Device"
	Identifier  "Card0"
#	Driver      "ati"
	Driver      "radeon"
	Option      "MonitorLayout"  "LVDS, SVGA"
	VendorName  "ATI Technologies Inc"
	BoardName   "Radeon RV200 LX [Mobility FireGL 7800 M7]"
	BusID       "PCI:1:0:0"
EndSection

Given that it is not a problem with Xorg itself but rather with the way X is set
up in Fedora, I would have thought that reporting it to Xorg would not be
productive.

Comment 6 Mike A. Harris 2005-09-14 08:56:21 UTC
It isn't a problem with the way X gets configured, it is a problem in that
the driver does not autodetect the hardware properly and make it
automatically do what you expect.  If the driver can't autodetect things
and automatically work without configuration, then the configuration tool
can't autodetect it either, and you have to specify the configuration
manually no matter what.

So this is a driver problem, and must be filed at X.org.


Note You need to log in before you can comment on or make changes to this bug.