Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162706 - iscsi_sfnet driver uses bounce buffers when it does not need to on ia64
Summary: iscsi_sfnet driver uses bounce buffers when it does not need to on ia64
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike Christie
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-07 21:18 UTC by Mike Christie
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 18:58:37 UTC


Attachments (Terms of Use)

Description Mike Christie 2005-07-07 21:18:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The iscsi_sfnet driver does not handle high mem becuase its kmap code is broken (it does a loop with multiple kmap without kunmapping). There is no HW limitation like with some real HW cards. For ia64 though, high mem is set but the kernel memory is mapped. Since the driver does not support high mem only becuase it needs to touch the buffers and to do so it will need to use kmap if the mem is not mapped for ia64 we incorrectly tell the block and scsi layer we need bounce buffers.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. setup iscsi on ia64
2. run IO to iscsi devices and see bounce buffers being used
3.
  

Expected Results:  iscsi driver should not have used bounce buffers

Additional info:

Comment 1 RHEL Product and Program Management 2007-10-19 18:58:37 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.