Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162702 - System hangs with ati driver
Summary: System hangs with ati driver
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-07 20:41 UTC by David Goldsmith
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-30 13:59:40 UTC


Attachments (Terms of Use)

Description David Goldsmith 2005-07-07 20:41:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
System is a dual-CPU Dell PowerEdge 1400SC, 1 GB RAM, ATI Mach 64 video on board.

I performed a fresh install of Fedora Core 4 several days ago into an empty partition. After installation, my /etc/X11/xorg.conf file had the following: 

Section "Device"
        Identifier  "Videocard0"
        Driver      "ati"
        VendorName  "Videocard vendor"
        BoardName   "ATI Mach64"
EndSection

This configuration was identical to what I had in Fedora Core 3.

I experienced numerous X server hangs. The system would just lock up after anywhere from 15-60 minutes of use - various activities such as VPN, Firefox, Thunderbird, OpenOffice.org, etc. Once it locked, I was unable to regain control other than via a reboot. I never experienced this problem with Fedora Core 3 running on the same computer.

After some research on the web, I thought to try switching to the generic VESA driver. After running the video config utility, my /etc/X11/xorg.conf file had the following: 

Section "Device"
        Identifier  "Videocard0"
        Driver      "vesa"
        VendorName  "Videocard vendor"
        BoardName   "VESA driver (generic)"
EndSection

I have been up and running for about 4 hours now with the generic VESA driver. So it would seem that FC4 is having a problem with the ati driver. Don't know if this is a problem with the installer setting the wrong driver for FC4 for this card, or X, or something else. 

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
The problem is sporadic. X hangs sporadically after not a very long time into a login session.
  

Additional info:

Comment 1 David Goldsmith 2005-07-07 21:12:53 UTC
I spoke too soon! Literally 5 minutes after reporting this bug, my X session on
FC4 hung. No mouse, no keyboard, not cnlt+alt+backspace, just a good old reboot.

Back to FC3 until this one gets fixed unless someone knows a workaround. :-(

Comment 2 Olivier Baudron 2005-07-30 11:37:47 UTC
Can you test the latest rawhide version: xorg-x11-6.8.2-44 ?

Comment 3 David Goldsmith 2005-07-31 23:22:42 UTC
Easier fix - switched distros. Now on Ubuntu 5.04, without any problems.

Comment 4 Steve Jenson 2005-08-03 05:46:17 UTC
I have similar problems with FC4. I am currently running xorg-x11.x86_64
6.8.2-37. Would be happy to test 2-44 but am unsure of how to update to that
version. How can I run yum against rawhide? I should be CC'd on this bug now but
if not, feel free to drop me a note at stevej _at_ pobox.com.

Comment 5 Mike A. Harris 2005-08-30 13:59:40 UTC
Closing bug "CANTFIX" as the report doesn't have enough information
present to conclude what the exact problem is, and the reporter has
indicated they've switched distributions.  My assumption is that
the original reporter wont be available to provide additional information
and/or test things to help us narrow the problem down.

If anyone else experiences this problem using the latest Fedora Core 4
update, please file a brand new bug report with complete details, and
attach your X server log and config file.

Thanks in advance.


Note You need to log in before you can comment on or make changes to this bug.