Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162670 - SRPM Rebuild Fails
Summary: SRPM Rebuild Fails
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: php
Version: 3.0
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-07 14:21 UTC by Mauricio Gomes
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-12 14:53:09 UTC


Attachments (Terms of Use)

Description Mauricio Gomes 2005-07-07 14:21:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
Attempting to rebuild the SRPM for this particular release and arch results in a failure.

mysql versions:
mysql-3.23.58-16.RHEL3.1.i386
mysql-3.23.58-16.RHEL3.1.x86_64

Version-Release number of selected component (if applicable):
php-4.3.2-24.ent, php-4.3.2-23.ent (maybe more)

How reproducible:
Always

Steps to Reproduce:
1. Obtain the srpm for php-4.3.2-24.ent or php-4.3.2-23.ent
2. rpmbuild --rebuild <php-package>
3. Observe result
  

Actual Results:  configure: exit 1
+ make -j2
make: *** No targets specified and no makefile found.  Stop.
error: Bad exit status from /var/tmp/rpm-tmp.54158 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.54158 (%build)

Expected Results:  + exit 0

Additional info:

Comment 1 Joe Orton 2005-09-12 14:53:09 UTC
The PHP libdir build issues are less evident in RHEL4 and definitely all fixed
in Raw Hide due to a rewrite; marking as DEFERRED since trying to fix these in
RHEL3 will be destabilising.


Note You need to log in before you can comment on or make changes to this bug.