Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162642 - targeted policy prevents printing on shared printers
Summary: targeted policy prevents printing on shared printers
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-07 01:54 UTC by Fritz Elfert
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.25.1-7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-19 08:28:45 UTC


Attachments (Terms of Use)

Description Fritz Elfert 2005-07-07 01:54:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Printing from any smb client is impossible, because of a missing allow rule.
When trying to print, smbd reports the following error in syslog:

smbd: print_job_start: insufficient permissions to open spool file /var/spool/samba/smbprn.....

Adding the following rule fixes the problem:

allow smbd_t var_spool_t:dir search;

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.23.18-17

How reproducible:
Always

Steps to Reproduce:
1. Try printing to any smb exported printer
2.
3.
  

Actual Results:  Printing is denied

Expected Results:  Printing should work

Additional info:

Comment 1 Daniel Walsh 2005-07-11 17:27:32 UTC
Fixed in  selinux-policy-targeted-1.25.1-7


Note You need to log in before you can comment on or make changes to this bug.