Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162640 - kernel panic and hang on boot w/ audio cd in drive
Summary: kernel panic and hang on boot w/ audio cd in drive
Keywords:
Status: CLOSED DUPLICATE of bug 162347
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alan Cox
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-07 00:52 UTC by Shahms E. King
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-12 22:05:24 UTC


Attachments (Terms of Use)

Description Shahms E. King 2005-07-07 00:52:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When booting the latest kernel with an audio CD in the drive, the kernel panic and the computer freezes.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1387_FC4

How reproducible:
Always

Steps to Reproduce:
1. Insert an audio CD in the drive
2. Reboot the computer
3. Watch the panic, and press "Reset"
  

Actual Results:  The kernel panics (in the cdrom IRQ handler, it hangs before starting klogd so I can't get the panic message).

Expected Results:  The kernel should successfully boot, at most noting that the cd is not a data cd.

Additional info:

  The CD-drive is a Plextor PX-716A.  The motherboard is an nForce3. kernel-2.6.11-1.1369_FC4 does not panic nor freeze, but does issue a series of errors:

Jul  6 17:16:31 home kernel: hdc: command error: status=0x51 { DriveReady SeekComplete Error }
Jul  6 17:16:31 home kernel: hdc: command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
Jul  6 17:16:31 home kernel: ide: failed opcode was: unknown
Jul  6 17:16:31 home kernel: ATAPI device hdc:
Jul  6 17:16:31 home kernel:   Error: Illegal request -- (Sense key=0x05)
Jul  6 17:16:31 home kernel:   Illegal mode for this track or incompatible medium -- (asc=0x64, ascq=0x00)
Jul  6 17:16:31 home kernel:   The failed "Read 10" packet command was:
Jul  6 17:16:31 home kernel:   "28 00 00 00 00 00 00 00 10 00 00 00 00 00 00 00
"
Jul  6 17:16:31 home kernel: end_request: I/O error, dev hdc, sector 0
Jul  6 17:16:31 home kernel: printk: 8 messages suppressed.
Jul  6 17:16:31 home kernel: Buffer I/O error on device hdc, logical block 0
Jul  6 17:16:31 home kernel: Buffer I/O error on device hdc, logical block 1

....

That's repeated a bit, but the computer boots and works fine.

Comment 1 Oliver Andrich 2005-07-10 09:32:07 UTC
I just wanted to drop a note, that this also happens on my Athlon XP 2500+
machine. It is not limited to x86_64. I am using an Gigabyte 7N400 Pro 2 board
with an nforce 2 chipset. I also experience it only in the 2.6.12 series of
kernels. 2.6.11 is okay for me.

Comment 2 Dan Carpenter 2005-07-10 16:41:11 UTC
Then sounds like bug 162347

Comment 3 Shahms E. King 2005-07-12 22:05:24 UTC

*** This bug has been marked as a duplicate of 162347 ***


Note You need to log in before you can comment on or make changes to this bug.