Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162629 - mailparse extension gives undefined symbol: mbfl_convert_filter_new
Summary: mailparse extension gives undefined symbol: mbfl_convert_filter_new
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: php-pecl-mailparse
Version: 4
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-06 22:16 UTC by Tom Fishwick
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.1.1-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-07 13:16:03 UTC


Attachments (Terms of Use)

Description Tom Fishwick 2005-07-06 22:16:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Installed php-mbstring-5.0.4-10.3, then installed php-pecl-mailparse-2.1-2

executing 'php -v' gives

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/mailparse.so' - /usr/lib/php/modules/mailparse.so: undefined symbol: mbfl_convert_filter_new in Unknown on line 0

putting "extension=mbstring.so" at the top of /etc/php.ini fixes the problem. So it seem to be a simple extension order loading issue.

Version-Release number of selected component (if applicable):
php-pecl-mailparse-2.1-2 php-mbstring-5.0.4-10.3 php-5.0.4-10.3

How reproducible:
Always

Steps to Reproduce:
1. install php-pecl-mailparse
2. run "php -v"
  

Actual Results:  PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/mailparse.so' - /usr/lib/php/modules/mailparse.so: undefined symbol: mbfl_convert_filter_new in Unknown on line 0
PHP 5.0.4 (cli) (built: Jul  4 2005 10:39:59)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.4-dev, Copyright (c) 1998-2004 Zend Technologies


Expected Results:  PHP 5.0.4 (cli) (built: Jul  4 2005 10:39:59)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.4-dev, Copyright (c) 1998-2004 Zend Technologies

Additional info:

Comment 1 Joe Orton 2005-07-07 09:34:02 UTC
There's no magic fix for this.  php-pecl-mailparse package should bundle an .ini
file which will sort alphabetically after the mbstring.ini; if it does that this
should work deterministically.

Possibly we should move to using a numeric prefix for the ini filenames as this
kind of thing becomes more common.

Comment 2 Adam J. Griff, Ph.D. 2005-08-25 18:54:06 UTC
Another fix that works but not the best solution.
edit /etc/php.d/mbstring.ini and comment out the extension
edit /etc/php.d/mailparse.ini and add 
extension=mbstring.so

If you don't comment out mbstring.ini you get a duplicate load error.

Comment 3 Joe Orton 2005-09-08 10:25:11 UTC
This needs to be fixed in the mailparse package, either way.

Comment 4 Matthias Saou 2005-09-08 10:51:08 UTC
Yup, exactly. I don't recall exactly when this changed, but this problem
appeared only recently, possibly when mbstring got split out as a shared module.
I thought I already had fixed this, but maybe I didn't yet commit the change,
which I'll then do very shortly.

Comment 5 Matthias Saou 2005-11-07 13:16:03 UTC
Sorry for the delay. I thought I had already fixed this, but it turns out that I
hadn't commited the change. It is now done at last.


Note You need to log in before you can comment on or make changes to this bug.