Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162567 - Screen goes blank when switching from init 5 to init 3
Summary: Screen goes blank when switching from init 5 to init 3
Keywords:
Status: CLOSED DUPLICATE of bug 161242
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-06 13:06 UTC by Shrinivas Varanasy
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-08 08:53:16 UTC


Attachments (Terms of Use)

Description Shrinivas Varanasy 2005-07-06 13:06:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I installed Fedora core 4 on my Inspiron 700m Laptop.
The installation and everything was successful.
Problem:
When switching from init 5 to init 3 the screen goes blank.
I set the Monitor : Generic Laptop LCD 1280*800
          Display device : intel 855
          Screen resolution : 1280 x 800

Any help please..

Thanks in advance
Shrinivas

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.edited /etc/inittab to default run level 5
2.#system-config-display 
3.Changed drivers 
4.rebooted
5.at GUI desktop opened terminal
6.# init 3

  

Actual Results:  Screen goes blank

Expected Results:  Command line interface (init level 3)

Additional info:

Comment 1 Sergio Monteiro Basto 2005-07-07 17:18:27 UTC
Funny I have a similar problem but with my intel 810, (desktop PIII 500 mhz), 
when switch from init level 5 to init level 3 sometimes becomes all in blue
colors instead of black.

Comment 2 Shrinivas Varanasy 2005-07-08 08:53:16 UTC
(In reply to comment #1)
> Funny I have a similar problem but with my intel 810, (desktop PIII 500 mhz), 
> when switch from init level 5 to init level 3 sometimes becomes all in blue
> colors instead of black.

After submitting the bug,I had gone through the existing bugs related to
xorg-X11 and fortunately found a solution.
Solution:
1. Downloaded libvgahw.a from ftp://people.redhat.com/mharris/libvgahw.a
2. Replaced the existing /usr/X11R6/lib/modules/libvgahw.a with the downloaded
one   
3. #system-config-display 
4. Monitor type : Generic LCD 1280x800
   Display device : Intel 855
and saved the configuration.
Once I rebooted I see that my problem is solved.

Sergio,

In your case follow the above steps from 1-3 and set the display device to Intel
810, As I dont know which monitor you are using If it is listed fine else select
Generic LCD/CRT 1280x800.
reboot the machine.
And see your problem is solved.. congrats.
I assumed you have installed FC-4.
for more details you may look into
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161242

*** This bug has been marked as a duplicate of 161242 ***


Note You need to log in before you can comment on or make changes to this bug.