Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162561 - Kernel - ACPI no poweroff
Summary: Kernel - ACPI no poweroff
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-06 11:07 UTC by Jim Cornette
Modified: 2015-01-04 22:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-18 01:59:32 UTC


Attachments (Terms of Use)
Kernel startup log (deleted)
2005-07-06 11:09 UTC, Jim Cornette
no flags Details
kernel-2.6.12-1.1400_FC5 dmesg (deleted)
2005-07-07 02:40 UTC, Jim Cornette
no flags Details
/var/log/messages (deleted)
2005-07-07 02:44 UTC, Jim Cornette
no flags Details

Description Jim Cornette 2005-07-06 11:07:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-2

Description of problem:
When trying to shutdown my computer, it failed to poweroff. With kernel-2.6.12-1.1411_FC5 my computer would not even boot. The last bootable kernel version and version that successfully shutdown was kernel-2.6.12-1.1400_FC5


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1413_FC5

How reproducible:
Always

Steps to Reproduce:
1. boot kernel
2. use system
3. poweroff
  

Actual Results:  Booting worked for the latest version. The previous version hung while booting. The version before seemed to work acceptably.

Expected Results:  The earlier version should have booted. This version should have shutdown as well.

Additional info:

This problem is a bit better than the problem experienced with the latest FC4 version which would not boot either. The acpi poweroff problem is too familiar and was a problem seen during FC3 revisited.

Comment 1 Jim Cornette 2005-07-06 11:09:31 UTC
Created attachment 116404 [details]
Kernel startup log

Comment 2 Jim Cornette 2005-07-07 02:36:02 UTC
Both the smp and the single processor kernels failed to poweroff. Included is
dmesg from the last kernel that would power down properly.

Comment 3 Jim Cornette 2005-07-07 02:40:21 UTC
Created attachment 116453 [details]
kernel-2.6.12-1.1400_FC5  dmesg

Both kernel-2.6.12-1.1421_FC5 and kernel-smp-2.6.12-1.1421_FC5 still fail to
power down properly.

Comment 4 Jim Cornette 2005-07-07 02:44:42 UTC
Created attachment 116454 [details]
/var/log/messages

Messages from booting the smp kernel uniprocessor kernel and the 1400 kernel
from today.

Comment 5 Dave Jones 2005-07-07 23:29:14 UTC
*** Bug 160775 has been marked as a duplicate of this bug. ***

Comment 6 Martin 2005-07-12 17:12:51 UTC
the last messages after 'shutdown -h now' with kernel-2.6.12-1.1426_FC5 are:

'unmounting file systems:
Halting system ...
md: stopping all md devices.
md: md0 switched to read-only mode.'

can someone tell me, where i can get the kernel-2.6.12-1.1400_FC5

Comment 7 Jim Cornette 2005-07-14 22:57:11 UTC
You might try a kernel from FC4 and boot with it until FC5 gets a working kernel
again. I have 2.6.12-1.1390_FC4 installed and it works decent. Development
appears to have 1432 in the repository. I have not tried it yet though.
Keep the FC4 kernel and check the devel repo to see if one comes pout that works
again.
Use the --oldpackage option for rpm to *install* the older kernel version. Read
man rpm to see the options for rpm.

Comment 8 Martin 2005-07-16 13:01:48 UTC
problem still exists with kernel-2.6.12-1.1433_FC5.i686.rpm

Comment 9 Jim Cornette 2005-07-18 01:56:50 UTC
kernel-2.6.12-1.1434_FC5 shuts down properly and seems to work quicker than
1400. (Not timed, but seems more responsive.)


Comment 10 Martin 2005-08-03 17:04:08 UTC
kernel-2.6.12-1.1446_FC5 seems to print more messages, but power off fails again:

Halting system ...
md: md0 switched to read-only mode.
ACPI: PCI interrupt for device 0000:02:01.0 disabled
ACPI: PCI interrupt for device 0000:00:1f.5 disabled

Comment 11 stef 2005-09-04 18:53:10 UTC
2.6.13 vanilla power-off works, see bug 160775

Comment 12 Martin 2005-09-09 16:22:22 UTC
the problem still exists with 2.6.13 vanilla kernel, the kernel do not poweroff
my  machine with the MSI Board.

Comment 13 Martin 2005-09-30 21:25:02 UTC
problem still exists with 2.6.13-1.1526_FC4

Comment 14 Martin 2005-11-10 20:17:42 UTC
problem still exists with kernel-2.6.14-1.1636_FC4.i686.rpm

Comment 15 Martin 2006-01-10 07:41:45 UTC
a good day for peoples with the mSI MS-6758 (875P Neo) Board.
With kernel-2.6.15-1.1823_FC4.i686.rpm the problem doesn't longer exists.
'shutdown -h now' works for me.



Note You need to log in before you can comment on or make changes to this bug.