Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162560 - missing buildrequires e2fsprogs-devel
Summary: missing buildrequires e2fsprogs-devel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cryptsetup-luks
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 176502 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-06 11:05 UTC by Karsten Hopp
Modified: 2014-03-17 02:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 15:39:25 UTC


Attachments (Terms of Use)

Description Karsten Hopp 2005-07-06 11:05:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
Rebuild on a minimal buildsystem:

...
checking for ctype.h... yes
checking for unistd.h... (cached) yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking uuid/uuid.h usability... no
checking uuid/uuid.h presence... no
checking for uuid/uuid.h... no
configure: error: 'You need the uuid library (from e2fsprogs)'
error: Bad exit status from /var/tmp/rpm-tmp.77831 (%build)

Version-Release number of selected component (if applicable):
cryptsetup-luks-1.0.1-1

How reproducible:
Always

Steps to Reproduce:
1. install minimal buildsystem (or remove e2fsprogs-devel package)
2. build package
3.
  

Actual Results:  build aborts

Additional info:

Comment 1 Bill Nottingham 2005-07-06 15:39:25 UTC
It was in there as e2fsprogs instead of e2fsprogs-devel. Fixed, will get picked
up at the next build.

Comment 2 Bill Nottingham 2005-12-24 03:34:34 UTC
*** Bug 176502 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.