Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162555 - gulm use the wrong network interface
Summary: gulm use the wrong network interface
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gulm
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: michael conrad tadpol tilstra
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-06 10:03 UTC by Alban Crequy
Modified: 2009-04-16 20:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 13:18:46 UTC


Attachments (Terms of Use)

Description Alban Crequy 2005-07-06 10:03:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.2) Gecko/20040804

Description of problem:
Gulmd use the default network interface to communicate with other nodes, instead of the network interface I set in nodes.ccs

Version-Release number of selected component (if applicable):
GFS-6.0.2.20-2

How reproducible:
Always

Steps to Reproduce:
1. Get a cluster with one gulm server.
2. Set nodes.ccs with the network interface I want (eth1):
ip_interfaces {
                eth1 = "192.168.1.124"
} ...
3. Start GFS.
4. Start a program that use a lot of locks/unlocks between the nodes
3. Check with tcpdump eth0 and eth1 on port 41040(gulm) that gulm use eth0 or eth1.


Actual Results:  tcpdump show that gulm use eth0 (192.168.0.124) instead of eth1 (192.168.1.124).

Expected Results:  tcpdump should show that gulm use eth1 because I set eth1 in nodes.ccs and I set the IP of eth1 in nodes.ccs

Additional info:

The relevant code is in:
gfs-6.0.2.20/gulm/daemon/main_main.c:157:set_myID().

This piece of code have changed in the CVS version:
cluster/gulm/src/main_main.c:154:set_myID().

But need to use a stable version of GFS on a Linux kernel 2.4.

Comment 1 michael conrad tadpol tilstra 2005-07-06 12:52:28 UTC
you did remember to add the following line to each node entry, right?
  usedev = "eth1"



Comment 2 Alban Crequy 2005-07-06 13:16:29 UTC
No, I didn't know the option "usedev". And the documentation
http://www.redhat.com/docs/manuals/csgfs/admin-guide/s1-sf-nodes.html
does not mention it, but I just find the documentation errata
http://www.redhat.com/docs/errata/csgfs/ which mention it.

Thank you for your help. I guess you can close this bug now.



Note You need to log in before you can comment on or make changes to this bug.