Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162550 - broken Requires: libpixman-devel >= %{pixman_version}
Summary: broken Requires: libpixman-devel >= %{pixman_version}
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cairo
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-06 08:09 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 14:49:04 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2005-07-06 08:09:13 UTC
Undefined RPM macro %{pixman_version} found in package dependencies:

$ rpm --query cairo-devel
cairo-devel-0.5.1-4

$ rpm --query --requires cairo-devel
cairo = 0.5.1-4
fontconfig-devel >= 2.0
freetype-devel >= 2.1.3-3
libpixman-devel >= %{pixman_version}
libpng-devel  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
xorg-x11-devel  

Solution: Either define pixman_version in the spec or delete this minimum version.

Comment 1 Kristian Høgsberg 2005-07-06 14:49:04 UTC
Michael,

Thanks for pointing this out.  I already define libpixman_version, which is what
this macro should have been. cairo-0.5.1-5 has the fix and should be in rawhide
soon.


Note You need to log in before you can comment on or make changes to this bug.