Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162544 - Updating cryptsetup-luks from 1.0-1 to 1.0.1-0 breaks previously created volumes
Summary: Updating cryptsetup-luks from 1.0-1 to 1.0.1-0 breaks previously created volumes
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cryptsetup-luks
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-06 03:54 UTC by Jason Tackaberry
Modified: 2014-03-17 02:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 15:58:21 UTC


Attachments (Terms of Use)

Description Jason Tackaberry 2005-07-06 03:54:36 UTC
Did a "yum update" and noticed a filesystem created with cryptsetup using a
stock FC4 system was no longer mounting.  Rolling back to 1.0-1 fixed the
problem.  The following shell session adequately illustrates the problem:

[root@viper ~]# dd if=/dev/zero of=foobar bs=1M count=10
10+0 records in
10+0 records out
[root@viper ~]# rpm -q cryptsetup-luks
cryptsetup-luks-1.0-1
[root@viper ~]# losetup /dev/loop0 foobar
[root@viper ~]# echo blahblah | cryptsetup -c serpent-cbc-essiv:sha256 -s 256
create cp0 /dev/loop0
[root@viper ~]# dd if=/dev/zero of=/dev/mapper/cp0
dd: writing to `/dev/mapper/cp0': No space left on device
20481+0 records in
20480+0 records out
[root@viper ~]# md5sum /dev/loop0
fc001241299983f3d59c1ec234c56f6c  /dev/loop0
[root@viper ~]# yum -y update cryptsetup-luks &>/dev/null
[root@viper ~]# rpm -q cryptsetup-luks
cryptsetup-luks-1.0.1-0.fc4
[root@viper ~]# dmsetup remove cp0
[root@viper ~]# echo blahblah | cryptsetup -c serpent-cbc-essiv:sha256 -s 256
create cp0 /dev/loop0
[root@viper ~]# dd if=/dev/zero of=/dev/mapper/cp0
dd: writing to `/dev/mapper/cp0': No space left on device
20481+0 records in
20480+0 records out
[root@viper ~]# md5sum /dev/loop0
44afd074d4b9f1b0d73b01198901fe4a  /dev/loop0

Notice the md5sum of the loop-backed file is different between the two versions.

Comment 1 Bill Nottingham 2005-07-06 15:41:50 UTC
From: 
  http://luks.endorphin.org/dm-crypt
- Fixed hash inconsistancy bug between cryptsetup-luks and original for piped
passwords.

So, it's either be compatibile with earlier releases of cryptsetup (i.e., FC3),
or compatible with what was shipped in FC4. :/

Comment 2 Jason Tackaberry 2005-07-06 15:52:45 UTC
Interesting dilemma.  Seeing as the regression is actually in 1.0-1 and not
1.0.1-0, and backward compatibility with FC3 is probably more important, I
suppose I'd be inclined to mark this NOTABUG, with apologies to annoyed users
like myself who have to rebuild their volumes. :)



Comment 3 Bill Nottingham 2005-07-06 15:58:21 UTC
Yeah, fixing the regression from FC3 was sort of the reason for the upgrade.
It's unfortunate that that wasn't noticed before FC4.


Note You need to log in before you can comment on or make changes to this bug.