Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162533 - jpackage-utils should not own /usr/share/javadoc/java
Summary: jpackage-utils should not own /usr/share/javadoc/java
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: jpackage-utils
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 162534
TreeView+ depends on / blocked
 
Reported: 2005-07-05 21:27 UTC by Ian Pilcher
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.6.6-1jpp_2rh
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-06 20:36:42 UTC


Attachments (Terms of Use)
Proposed changes to jpackage-utils SPEC file (deleted)
2005-07-07 19:14 UTC, Ian Pilcher
no flags Details | Diff

Description Ian Pilcher 2005-07-05 21:27:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
jpackage-utils-1.6.3-1jpp_1rh owns /usr/share/javadoc/java.  This
creates a conflict with classpath-javadoc (in JPackage currently
and being considered for Fedora Core).

Version-Release number of selected component (if applicable):
jpackage-utils-1.6.3-1jpp_1rh

How reproducible:
Always

Steps to Reproduce:
1.  rpm -ihv classpath-javadoc-0.15-1jpp.noarch.rpm


Actual Results:  Preparing...                ########################################### [100%]
        file /usr/share/javadoc/java from install of classpath-javadoc-0.15-1jpp conflicts with file from package jpackage-utils-1.6.3-1jpp_1rh


Expected Results:  Installation should succeed (no conflict).

Additional info:

Comment 1 Ian Pilcher 2005-07-07 19:14:46 UTC
Created attachment 116486 [details]
Proposed changes to jpackage-utils SPEC file

Comment 2 Thomas Fitzsimmons 2005-07-07 19:30:41 UTC
Some packages require this directory for building, so I don't think we should
remove it until we have a suitable replacement.  I like the idea of libgcj-docs
(built as part of the GCC RPM) and java-1.4.2-gcj-compat-doc you proposed on
fedora-devel-java-list.  I'm going to hold off committing this until those
packages are available.


Comment 3 Ian Pilcher 2005-07-07 20:58:53 UTC
libgcj-docs will have to wait until at least the next GCC update.  (And
there's no indication in #162534 yet of how Jakub feels about this idea.)

In the meantime, jpackage-utils conflicts with the API documentation
packages from JPackage (java-1.4.2-javadoc, etc.).  What do you think of
rolling out the "compat-doc" package, with an empty /usr/src/javadoc/java
directory, in the interim?  This would allow people to at least install
the documentation packages from JPackage without using --force.

Comment 4 Thomas Fitzsimmons 2005-07-07 21:01:50 UTC
Actually, that was exactly what we did as a first attempt to solve this.  But
releng rejects empty packages for some reason.  Maybe we should include
classpath-javadocs in Fedora for now.

Comment 5 Ian Pilcher 2005-07-07 21:26:18 UTC
I've never heard of releng, but java-1.4.2-gcj-compat-src is empty.

Comment 6 Thomas Fitzsimmons 2005-07-07 21:49:08 UTC
releng is release engineering.  Yeah, you're right, we did slip in
java-1.4.2-gcj-compat-src.  Maybe that's acceptable because it's a sub-package.
 Anyway, I'd rather include classpath-javadocs I think.  I'll look at building
it in soon.


Comment 7 Ian Pilcher 2005-10-25 17:10:07 UTC
Isn't it about time that this got fixed, even if the fix isn't perfect?

At the very least, this should be a FC5 blocker.

Comment 8 Alan Lue 2005-11-18 05:44:14 UTC
I had a similar problem with an identical cause: I couldn't install
java-1.5.0-javadoc-1.5.0-1jpp because jpackage-utils v1.6.3 (from Fedora Extras)
owned /usr/share/javadoc/java.  Upgrading to jpackage-utils-1.6.6-1jpp from the
jpackage.org yum repo solved the problem, as it allowed the installation of the
javadoc package.

Comment 9 Thomas Fitzsimmons 2006-02-06 20:36:42 UTC
I've removed this directory from jpackage-utils and introduced
java-1.4.2-gcj-compat-javadoc which contains gjdoc-generated libgcj API
documentation, installed in /usr/share/javadoc/java.  Closing.



Note You need to log in before you can comment on or make changes to this bug.