Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162524 - kernel 2.6.12-1.1387/1390 panic just after init
Summary: kernel 2.6.12-1.1387/1390 panic just after init
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
: 165284 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-05 20:18 UTC by J.Jansen
Modified: 2015-01-04 22:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-31 23:20:55 UTC


Attachments (Terms of Use)

Description J.Jansen 2005-07-05 20:18:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
kernel-2.6.12-1.1387 panics with the following message on my machine
(mobo : asus p4p800 with 2 Sata drives)

....
Redhat nash version 4.2.15 starting
mkrootdev : label / not found
mount: error 2 mounting ext3
ERROR opening /dev/console!!!!:2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fd of 0 to 2
switchroot: mount failed: 22
kernel panic - not syncing : Atempt to kill init?


BTW kernel-2.6.11-1.1369 with the same boot options just works fine on this
machine.

           Jouk Jansen



Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1387

How reproducible:
Always

Steps to Reproduce:
1.boot into 2.6.12-1.1387 kernel
2.
3.
  

Actual Results:  system hang at start of boot

Expected Results:  normal boot

Additional info:

Comment 1 Dan Carpenter 2005-07-05 20:43:21 UTC
The key line is:

> mkrootdev : label / not found

A module is not being loaded correctly.  There have been a bunch of 
problems with mkinitrd screwing up recently so that could be the 
problem.
cd /tmp
zcat /boot/initrd*2.6.12-1.1387*img | cpio -idmv
Poke through the linuxrc file to make sure all the correct modules are 
being loaded.


Comment 2 J.Jansen 2005-07-11 06:18:06 UTC
kernel 2.6.12.1-1390 gives exactly the same problem

Comment 3 J.Jansen 2005-07-11 06:21:47 UTC
to Comment #1 : the zcat |cpio give a reasoble output. I was not able to locate
the linuxrc file.



Comment 4 J.Jansen 2005-07-12 20:24:53 UTC
It seems that some modules are not in the zcat |cpio list:

missing :

lib/libata.ko
lib/sd_mod.ko
lib/scsi_mod.ko
lib/ata_piix.ko

Why are they missing and how do I get them in correctly?

Comment 5 Dan Carpenter 2005-07-12 21:03:49 UTC
There have been a bunch of these mkinitrd bugs in the last couple weeks.  

For example, see bug 162868 which is the same as yours.

I know a couple people have said they upgraded their mkinitrd rpm and that fixed
the problem but I can't find those bug reports right off the bat.



Comment 6 J.Jansen 2005-07-12 21:14:11 UTC
I got the in the initrd*.img files with

mkinitrd --with scsci-mod /boot/initrd<kernelversion> <kernelversion>

seems that you have to give expiclitely the --with option
putting somethinf in /etc/modprob.conf did not work for me.

But in principle when installing a new kernel everything should be automatically
configured correctly. So do I have to do the mkinitrd every time I will upgrade
a kernel in future?


Comment 7 J.Jansen 2005-07-12 21:17:45 UTC
in recation on comment #5 : I'm running the  latest mkinitrd realeased for FC4.
So that one should be suitable for every released FC4 kernel.



Comment 8 Dan Carpenter 2005-07-13 04:46:33 UTC
The --with scsci-mod is a temporary work around until the bug is fixed properly.

Check back in a couple weeks.



Comment 9 Dave Jones 2005-07-15 21:02:40 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 10 J.Jansen 2005-07-19 19:26:53 UTC
I did the kudzu procedure and installed the new kernel, but still the 3 modules
mentioned above are missing.


Comment 11 Dave Jones 2005-07-28 19:48:10 UTC
what does your /etc/modprobe.conf look like after the procedure above ?

Comment 12 Gerwin Krist 2005-08-07 18:41:04 UTC
*** Bug 165284 has been marked as a duplicate of this bug. ***

Comment 13 J.Jansen 2005-08-12 19:11:33 UTC
/etc/modeprobe.conf looks now like : 


beer-jj ) ls -al modprobe.conf
-rw-r--r--  1 root root 383 Jul 19 21:39 modprobe.conf
beer-jj ) cat modprobe.conf
alias eth0 sk98lin
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias ieee1394-controller ohci1394
alias scsi_hostadapter ata_piix
alias char-major-195* nvidia
beer-jj )

the last line maybe added later due to installation of the livna-nvidia driver.

Comment 14 Dave Jones 2005-08-26 22:47:41 UTC
Can you try with the latest kernel errata from updates-testing please ?


Comment 15 J.Jansen 2005-08-31 19:10:19 UTC
Kernel 1447 installs correct without the need of mkinitrd performed manually

Problem seems to be solved.




Note You need to log in before you can comment on or make changes to this bug.