Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162517 - [patch] rpm fails to build - generates zipped feature instead of tarball
Summary: [patch] rpm fails to build - generates zipped feature instead of tarball
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-pydev
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Pound
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-05 19:24 UTC by Robin Green
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: eclipse-pydev-0.9.3_fc-8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-05 19:47:05 UTC


Attachments (Terms of Use)
Fix (deleted)
2005-07-05 19:24 UTC, Robin Green
no flags Details | Diff

Description Robin Green 2005-07-05 19:24:03 UTC
Description of problem:
The eclipse-pydev RPM fails to build on rawhide. It generates a zipped feature
instead of a tarball (although the generated zip file still ends with .tar.gz).
This seems to be due to a change in eclipse. A patch to fix the build is attached.

Version-Release number of selected component (if applicable):
eclipse-pydev-0.9.3_fc-7

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -ba eclipse-pydev.spec
  
Actual results:
<snip>
rootFileslinux_gtk_x86:
      [zip] Building zip:
/usr/src/redhat/BUILD/eclipse-pydev-0.9.3_fc/org.python.pydev.releng/results/I.I200507052017/eclipse-pydev.tar.gz
      [zip] Updating zip:
/usr/src/redhat/BUILD/eclipse-pydev-0.9.3_fc/org.python.pydev.releng/results/I.I200507052017/eclipse-pydev.tar.gz
   [delete] Deleting directory
/usr/src/redhat/BUILD/eclipse-pydev-0.9.3_fc/org.python.pydev.releng/results/tmp

postAssemble:

package:

postBuild:

postBuild:
BUILD SUCCESSFUL

BUILD SUCCESSFUL
Total time: 45 seconds
+ mkdir native
+ pwd
/usr/src/redhat/BUILD/eclipse-pydev-0.9.3_fc/org.python.pydev.releng
+ for file in 'results/I.*/*.tar.gz'
+ case $file in
+ tar -zx -C native -f results/I.I200507052017/eclipse-pydev.tar.gz '*.jar'
gzip: stdin has more than one entry--rest ignored
tar: Child returned status 2
tar: *.jar: Not found in archive
tar: Error exit delayed from previous errors
error: Bad exit status from /var/tmp/rpm-tmp.94791 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.94791 (%build)

Expected results:
Successful build

Comment 1 Robin Green 2005-07-05 19:24:04 UTC
Created attachment 116376 [details]
Fix

Comment 2 Jeff Pound 2005-07-05 19:47:05 UTC
Applied and pushed to rawhide.
Thanks for the patch :)


Note You need to log in before you can comment on or make changes to this bug.